myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bertrand, Shawn R" <shawn.bertr...@tycoelectronics.com>
Subject RE: [Trinidad] Update from 1.0.1 to 1.0.3 breaks PPR
Date Tue, 16 Oct 2007 16:18:31 GMT
During the PPR request, do you happen to disable the component which
originated the request?  We see something similar to this, though not
the same error, when a commandButton is clicked to start PPR and we
disable the button in an actionListener.  We had been using 1.0.2 and
had to leave our buttons enabled all the time to avoid this error, but
hope to get it working with 1.0.3.

 

Shawn Bertrand

Tyco Electronics Corporation

 

 

________________________________

From: Francisco Passos [mailto:francisco.passos@gmail.com] 
Sent: Tuesday, October 16, 2007 10:11 AM
To: MyFaces Discussion
Subject: Re: [Trinidad] Update from 1.0.1 to 1.0.3 breaks PPR

 

Simon,

unfortunately clearing the browser cache didn't seem to do anything :(

Francisco

On 10/16/07, Simon Lessard < simon.lessard.3@gmail.com
<mailto:simon.lessard.3@gmail.com> > wrote:

Hello Francisco,

Let try an easy attempt then (and very unlikely to work), try to clear
your browser cache. :) 

That issue is quite a nuisance as you're not the first to report it and
none of the dev team can reproduce it to my knowledge. 


Regards,



~ Simon

On 10/16/07, Francisco Passos < francisco.passos@gmail.com
<mailto:francisco.passos@gmail.com> > wrote: 

Hello Simon,

I've just tried 1.0.2 and the same problem happens (plus some changes in
the way panelBoxes appear). 

If you need more information that I can provide, please feel free to
ask. I actually need to upgrade to 1.0.3 in the next few days or not
upgrade at all.

Francisco





On 10/16/07, Simon Lessard <simon.lessard.3@gmail.com > wrote:

Hello Francisco,

Can you try with 1.0.2 first please? This is not the first post we get
about issues such as this one and we would like to locate it more
precisely so knowing if the problem was introduced with 1.0.2 or 1.0.3
would certainly helps.

Thanks,

~ Simon

 

On 10/16/07, Francisco Passos <francisco.passos@gmail.com > wrote:

Good afternoon.

I've been developing an application with Trinidad 1.0.1 and am
considering upgrading to 1.0.3 for the improvements in PPR, the
statusIndicator and also to be able to redirect AJAX requests to the
login page after the session has expired. 

However, immediatly after replacing the 1.0.1 libs with their 1.0.3
counterparts, I find that AJAX interactions no longer work, generating
an error on the browser, which Firebug identifies this way:

["Invalid PPR response. The response-headers were:\nDate: Tue, 16 Oct
2007 13:09:56 GMT\nTransfer-Encodi..." ] Common1_0_3.js (line 10458) 
["Error ", TypeError: a5 has no properties message=a5 has no properties,
" delivering XML request status changed to " , function()] 

What can cause this and is there a workaround?

Thank you,

Francisco 

 

 





 


Mime
View raw message