myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <mat...@apache.org>
Subject Re: [Trinidad] can't run 1.0.3 under Eclipse embedded browser
Date Sat, 27 Oct 2007 14:25:20 GMT
ha! that is really strange.
any kind of JS-error show by that beast ?

-M

On 10/27/07, Renzo Tomaselli <renzo.tomaselli@tecnotp.it> wrote:
> Hi, I wonder if anybody succeeded to run a Trinidad 1.0.3-based
> application on the browser embedded in Eclipse, version 3.3 (latest) for
> Windows (or even 3.2).
> Trinidad 1.0.2 runs fine, while 1.0.3 does not. A simple page like this:
>
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
> "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
> <tr:document  xmlns:tr="http://myfaces.apache.org/trinidad">
>     <tr:form id="login">
>         <tr:commandButton text="hi" action="#{testBean.action}"/>
>     </tr:form>
> </tr:document>
>
> does not submit anything to the server from such browser. No action, no
> errors. Just flipping the jar pair trinidad-impl/api between 1.0.2 and
> 1.0.3 makes this problem flipping as well. No cache involved.
> I guess the problem is somewhere in js method submitForm(), but there is
> no client-side debugging available. Also I noticed that links do submit
> something, but Trinidad/Facelets machinery is not reached. Buttons do
> not even fire any request.
> Funny enough, FF 2.0, IE 6/7 have no problems. I read that the Eclipse
> embedded browser should be IE6, however IE6 runs fine while taken
> standalone.
>
> -- Renzo
>
>
>


-- 
Matthias Wessendorf

further stuff:
blog: http://matthiaswessendorf.wordpress.com/
mail: matzew-at-apache-dot-org

Mime
View raw message