myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Freedman <michael.freed...@oracle.com>
Subject Re: Myfaces/Tomahawk on IBM WebSphere Portal Server 6
Date Wed, 24 Oct 2007 16:50:35 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
FYI ... The preliminary RI for JSR-301 Faces Portlet Bridge should be
exposed as a new MyFaces subproject in the next day or two.&nbsp; You might
consider switching to using this bridge going forward as the JSR has/is
trying to account for all the various issues folks have run into with
past bridge's and provide as complete a solution as possible across as
many environments as possible.&nbsp; testing this work out in a WebSphere
environment would certainly help to strengthen the work on this JSR.<br>
&nbsp;&nbsp;&nbsp; -Mike-<br>
<br>
<a class="moz-txt-link-abbreviated" href="mailto:SJain@SperianProtection.com">SJain@SperianProtection.com</a>
wrote:
<blockquote
 cite="midOF49EED16F.BED985E2-ON8525737D.0065F1F1-8525737D.00668885@Bacou-Dalloz.com"
 type="cite"><br>
  <font face="sans-serif" size="2">I am using </font><font
 color="#4040c2" face="Courier New" size="2">MyFaces
Portlet Bridge</font><font face="sans-serif" size="2"><b> i.e. </b></font><font
 face="Courier New" size="2">MyFacesGenericPortlet</font><font
 face="sans-serif" size="2"><b>
for the portlet-class . Is that not the correct one ?</b></font>
  <br>
  <br>
  <font face="sans-serif" size="2"><b>Anyway , I'll try the one you
suggested
. Hope it works</b></font>
  <br>
  <br>
  <br>
  <font face="sans-serif" size="2">Thanks</font>
  <br>
  <font face="sans-serif" size="2">Shipra<br>
  </font>
  <br>
  <br>
  <br>
  <table width="100%">
    <tbody>
      <tr valign="top">
        <td width="40%"><font face="sans-serif" size="1"><b>Bernhard
Huemer <a class="moz-txt-link-rfc2396E" href="mailto:bernhard.huemer@gmail.com">&lt;bernhard.huemer@gmail.com&gt;</a></b>
        </font>
        <p><font face="sans-serif" size="1">10/23/2007 02:07 PM</font>
        <table border="1">
          <tbody>
            <tr valign="top">
              <td bgcolor="white">
              <div align="center"><font face="sans-serif" size="1">Please
respond to<br>
"MyFaces Discussion" <a class="moz-txt-link-rfc2396E" href="mailto:users@myfaces.apache.org">&lt;users@myfaces.apache.org&gt;</a></font></div>
              </td>
            </tr>
          </tbody>
        </table>
        <br>
        </p>
        </td>
        <td width="59%">
        <table width="100%">
          <tbody>
            <tr valign="top">
              <td>
              <div align="right"><font face="sans-serif" size="1">To</font></div>
              </td>
              <td><font face="sans-serif" size="1">MyFaces Discussion
<a class="moz-txt-link-rfc2396E" href="mailto:users@myfaces.apache.org">&lt;users@myfaces.apache.org&gt;</a></font>
              </td>
            </tr>
            <tr valign="top">
              <td>
              <div align="right"><font face="sans-serif" size="1">cc</font></div>
              </td>
              <td><br>
              </td>
            </tr>
            <tr valign="top">
              <td>
              <div align="right"><font face="sans-serif" size="1">Subject</font></div>
              </td>
              <td><font face="sans-serif" size="1">Re: Myfaces/Tomahawk
on IBM WebSphere
Portal Server 6</font></td>
            </tr>
          </tbody>
        </table>
        <br>
        <table>
          <tbody>
            <tr valign="top">
              <td>
              <br>
              </td>
              <td><br>
              </td>
            </tr>
          </tbody>
        </table>
        <br>
        </td>
      </tr>
    </tbody>
  </table>
  <br>
  <br>
  <br>
  <tt><font size="2">Hello,<br>
  <br>
I can't access the project at the moment, but the configuration is <br>
rather simple anyway. Due to the exception you've reported on this <br>
mailing list, I assume you're not using a Portlet Bridge? However, I've
  <br>
been using the Pluto Portal Bridge <br>
(<a class="moz-txt-link-freetext" href="http://portals.apache.org/bridges/multiproject/portals-bridges-jsf/index.html">http://portals.apache.org/bridges/multiproject/portals-bridges-jsf/index.html</a>).<br>
There's also a sample JSF portlet available!<br>
  <br>
You could also use the JSR-301 Portlet Bridge.<br>
  <br>
regards,<br>
Bernhard<br>
  <br>
On 10/23/2007 +0200,<br>
<a class="moz-txt-link-abbreviated" href="mailto:SJain@SperianProtection.com">SJain@SperianProtection.com</a>
wrote:<br>
&gt; <br>
&gt; Hello Bernhard<br>
&gt; <br>
&gt; Few weeks back , you mentioned that &nbsp;you got Myfaces successfully
  <br>
&gt; running on WebspherePortal 6 . &nbsp;Can you please send me a relavent
  <br>
&gt; snippet of your portlet.xml &amp; web.xml , where you configure
MyFaces
  <br>
&gt; related parameters.<br>
&gt; <br>
&gt; I am getting distorted pages &amp; null pointers when I switch
between
  <br>
&gt; portlets . &nbsp;Earlier I thought it was because of duplicate clientId
in <br>
&gt; tomhawk datascroller .So, I got rid of it &nbsp;. Duplicate clientid
issue is <br>
&gt; gone , but the Null pointers are still there which I am guessing
causing
  <br>
&gt; distorted pages.<br>
&gt; <br>
&gt; With the portlet &amp; web.xml , I just want to verify , if i have
  <br>
&gt; configured things correctly .<br>
&gt; <br>
&gt; Thanks<br>
&gt; Shipra<br>
&gt; <br>
&gt; <br>
&gt; <br>
&gt; *Bernhard Huemer <a class="moz-txt-link-rfc2396E" href="mailto:bernhard.huemer@gmail.com">&lt;bernhard.huemer@gmail.com&gt;</a>*<br>
&gt; <br>
&gt; 10/04/2007 01:58 PM<br>
&gt; Please respond to<br>
&gt; "MyFaces Discussion" <a class="moz-txt-link-rfc2396E" href="mailto:users@myfaces.apache.org">&lt;users@myfaces.apache.org&gt;</a><br>
&gt; <br>
&gt; <br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp;<br>
&gt; To<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp;MyFaces
Discussion <a class="moz-txt-link-rfc2396E" href="mailto:users@myfaces.apache.org">&lt;users@myfaces.apache.org&gt;</a><br>
&gt; cc<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp;<br>
&gt; Subject<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp;Re:
Myfaces/Tomahawk on IBM WebSphere Portal Server 6<br>
&gt; <br>
&gt; <br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp;<br>
&gt; <br>
&gt; <br>
&gt; <br>
&gt; <br>
&gt; <br>
&gt; Hello,<br>
&gt; <br>
&gt; which version of MyFaces and which portlet bridge are you using?
I'm<br>
&gt; just asking as I didn't face those exceptions. Perhaps, if I've
got
time<br>
&gt; left on the weekend, I'll create an example project (sort of
"archetype<br>
&gt; project").<br>
&gt; <br>
&gt; regards,<br>
&gt; Bernhard<br>
&gt; <br>
&gt; On 10/04/2007 +0200,<br>
&gt; <a class="moz-txt-link-abbreviated" href="mailto:SJain@SperianProtection.com">SJain@SperianProtection.com</a>
wrote:<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; We had tough time . Then finally we had to hack My Faces
( with help of<br>
&gt; &nbsp;&gt; IBM consultant ) to make it somewhat work . &nbsp;Of particular
note IBM<br>
&gt; &nbsp;&gt; support is useless . You have to pay them to get a
consultant.<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; Still getting duplicate clientId exceptions , due to which
page renders<br>
&gt; &nbsp;&gt; incorrectly when visited again in same session .<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; What stage are you at ? What is the error you are getting?<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; If someone have any solution to this , please let us know.<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; Shipra Jain<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; *<a class="moz-txt-link-rfc2396E" href="mailto:mario.buonopane@accenture.com">&lt;mario.buonopane@accenture.com&gt;</a>*<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; 10/04/2007 09:36 AM<br>
&gt; &nbsp;&gt; Please respond to<br>
&gt; &nbsp;&gt; "MyFaces Discussion" <a class="moz-txt-link-rfc2396E" href="mailto:users@myfaces.apache.org">&lt;users@myfaces.apache.org&gt;</a><br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp; &nbsp;
&nbsp;<br>
&gt; &nbsp;&gt; To<br>
&gt; &nbsp;&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp; &nbsp;
&nbsp;<a class="moz-txt-link-rfc2396E" href="mailto:users@myfaces.apache.org">&lt;users@myfaces.apache.org&gt;</a><br>
&gt; &nbsp;&gt; cc<br>
&gt; &nbsp;&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp; &nbsp;
&nbsp;<br>
&gt; &nbsp;&gt; Subject<br>
&gt; &nbsp;&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp; &nbsp;
&nbsp;Myfaces/Tomahawk on IBM WebSphere Portal Server 6<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
&nbsp; &nbsp;
&nbsp;<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; Hi, is there any one have used successfully Myfaces/Tomahawk
on IBM<br>
&gt; &nbsp;&gt; WebSphere Portal Server 6?<br>
&gt; &nbsp;&gt; &nbsp;<br>
&gt; &nbsp;&gt; Regards<br>
&gt; &nbsp;&gt; Mario Buonopane<br>
&gt; &nbsp;&gt; &nbsp;<br>
&gt; &nbsp;&gt;<br>
&gt; &nbsp;&gt; This message is for the designated recipient only and may
contain<br>
&gt; &nbsp;&gt; privileged, proprietary, or otherwise private information.
If you have<br>
&gt; &nbsp;&gt; received it in error, please notify the sender immediately
and delete<br>
&gt; &nbsp;&gt; the original. Any other use of the email by you is
prohibited.<br>
&gt; &nbsp;&gt;<br>
&gt; <br>
&gt; <br>
  <br>
  </font></tt>
  <br>
</blockquote>
</body>
</html>

Mime
View raw message