myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Björn Thalheim <bjoern.thalh...@gmx.de>
Subject [Trinidad] Double-Rendering-Problem
Date Tue, 18 Sep 2007 08:49:15 GMT
Hi,

I'm trying to get Trinidad running, so I used trinidad-blank and adapted 
the web.xml and faces-config.xml a little bit as well as the directory 
hierarchy.

When I do not put
  		<default-render-kit-id>
			org.apache.myfaces.trinidad.core
		</default-render-kit-id>
into the faces-config.xml, the backing-bean is being accessed, but the 
Trinidad rendering context cannot be found (which is exactly what one 
would expect in this case). When I put these lines into my 
faces-config.xml I get an interesting side-effect. My log files say 
about it (I'm using Glassfish):
<<<<< snip >>>>>
[#|2007-09-18T10:39:54.406+0200|WARNING|sun-appserver9.1|org.apache.myfaces.trinidad.context.RenderingContext|_ThreadID=16;_ThreadName=httpSSLWorkerThread-8080-0;_RequestID=e8b8cae1-1aae-4bd6-ab5c-fc298c8cffd7;|Trying

to attach RenderingContext to a thread that already had one.|#]

[#|2007-09-18T10:39:54.406+0200|WARNING|sun-appserver9.1|javax.enterprise.resource.webcontainer.jsf.renderkit|_ThreadID=16;_ThreadName=httpSSLWorkerThread-8080-0;_RequestID=e8b8cae1-1aae-4bd6-ab5c-fc298c8cffd7;|Unable

to find component with ID login in view.|#]

[#|2007-09-18T10:39:54.421+0200|WARNING|sun-appserver9.1|org.apache.myfaces.trinidadinternal.renderkit.core.CoreRenderKit|_ThreadID=16;_ThreadName=httpSSLWorkerThread-8080-0;_RequestID=e8b8cae1-1aae-4bd6-ab5c-fc298c8cffd7;|No

RenderingContext available|#]
<<<<< snap >>>>>

What happens is that the JSF navigation rules do not work any more with 
that. I guess it is because the pages are kind of doubly-rendered. If I 
enter the URL directly into my browser, the Trinidad-components are 
being displayed.

Looking for this error ("Trying to attach RenderingContext to a thread 
that already had one.") I have found some issues when these messages 
were caused by bugs 
(http://www.mail-archive.com/adffaces-dev@incubator.apache.org/msg02096.html) 
and legacy libraries 
(http://www.nabble.com/-Trinidad--RenderingContext-Error-when-STATE_SAVING_METHODis-%22client%22-t3920348.html),

but nothing which helps my issue.

If anybody has any idea how to get rid of this problem, please let me 
know. I attached my web.xml and my faces-config.xml here because my 
guess is that there is somewhere an error in these files. I am using the 
following libraries:
commons-beanutils-1.6.1.jar
commons-codec-1.2.jar
commons-collections-3.0.jar
commons-digester-1.5.jar
commons-el.jar
commons-fileupload-1.0.jar
commons-lang-2.1.jar
commons-logging.jar
jstl.jar
myfaces-api.jar
myfaces-impl.jar
sandbox.jar
tomahawk.jar
trinidad-api-1.2.2.jar
trinidad-impl-1.2.2.jar

Please write any mail on this to my personal email address as well as to 
the list, since I did not get any subscription confirmation yet.

Regards,

Björn

Mime
View raw message