myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Robinson" <andrew.rw.robin...@gmail.com>
Subject Re: Does MyFaces 1.2 require JSP 2.1?
Date Thu, 19 Jul 2007 17:10:21 GMT
JSF 1.2 requires JSP 2.1 unless you use facelets.

I believe you have to run Tomcat 6 as a minimum version (servlet 2.5
support is required)

On 7/19/07, mraible <matt@raibledesigns.com> wrote:
>
> I should mention: I get the error below on startup when deploying on Tomcat
> 5.0.25. If I change from MyFaces to Sun's RI and deploy on Tomcat 5.0.25
> again, no error.
>
> Matt
>
>
> mraible wrote:
> >
> > From what I can tell, MyFaces 1.2 requires JSP 2.1. I developed a quick
> > prototype using MyFaces 1.2 + Facelets 1.1.13 and I get the following
> > error on startup:
> >
> > Exception sending context initialized event to listener instance of class
> > org.apache.myfaces.webapp.StartupServletContextListener
> > java.lang.NoSuchMethodError:
> > javax.servlet.jsp.JspFactory.getJspApplicationContext(Ljavax/servlet/ServletContext;)Ljavax/servlet/jsp/JspApplicationContext;
> >         at
> > org.apache.myfaces.webapp.DefaultFacesInitializer.initFaces(DefaultFacesInitializer.java:102)
> >         at
> > org.apache.myfaces.webapp.StartupServletContextListener.contextInitialized(StartupServletContextListener.java:57)
> >
> > If I deploy my app to Tomcat 6, this problem doesn't exist. If I change
> > from MyFaces 1.2 to Sun's RI 1.2_04, this problem doesn't exist either.
> > For this reason, it appears to me that MyFaces 1.2 requires JSP 2.1.
> >
> > Cheers,
> >
> > Matt
> >
>
> --
> View this message in context: http://www.nabble.com/Does-MyFaces-1.2-require-JSP-2.1--tf4112432.html#a11693503
> Sent from the MyFaces - Users mailing list archive at Nabble.com.
>
>

Mime
View raw message