myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Marinschek" <martin.marinsc...@gmail.com>
Subject Re: Bug in <t:div> tag??
Date Sat, 30 Jun 2007 14:43:10 GMT
If only a getter is called, the ELResolver will return null - if you
try to call a setter (or a method-binding), you'll fall flat on the
nose with an exception.

regards,

Martin

On 6/30/07, Andrew Robinson <andrew.rw.robinson@gmail.com> wrote:
> Is your bean returning null?
>
> Try this to ensure that the tag/component is working:
>
> <t:div forceId="true" id="searchClosed" styleClass="#{'abcd'}" >
> 123
> </t:div>
>
> If that works, then you know it is the code.
>
> As for not throwing an error, I'm not sure of the situations where
> "Base is null" is thrown, or null is used. I know that most of the
> time #{blah} will return null for me if blah doesn't exist.
>
> On 6/29/07, Marty Bergerud <Marty_Bergerud@notes.ntrs.com> wrote:
> >
> > I am experiencing a problem with the <t:div> tag, I cannot load the
> > styleClass attribute from a backing bean. (The styleClass works fine when it
> > is a static entry) The funny thing is that I can pass a completely wrong
> > backing bean expression and Faces does not detect the error. Can someone
> > please try to reproduce this, It should be easy, just copy this code into
> > any jsf page and run it.
> >
> > <t:div forceId="true" id="searchClosed"
> > styleClass="#{doesNotExistBB.searchClosedClass}" >
> > 123
> > </t:div>
> >
> > I am using MyFaces 1.1.5
> > Thanks,
> > Marty
> >
>


-- 

http://www.irian.at

Your JSF powerhouse -
JSF Consulting, Development and
Courses in English and German

Professional Support for Apache MyFaces

Mime
View raw message