myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Fauerbach" <sc...@arondight.com>
Subject h:selectOneMenu bean properties not set in core 1.1.5, worked in 1.1.4
Date Tue, 22 May 2007 06:08:53 GMT
I upgraded from MyFaces Core/Impl 1.1.4 to 1.1.5 and the property setter 
never gets called even though the form is submitted (I have a phase listener 
that was called plus you could tell the browser makes a request). I went 
back to the 1.1.4 and it worked fine. I'm using the standard selectOneMenu 
component, not a tomahawk component.

JSF:
<h:form>
  <h:selectOneMenu value="#{MyBean.myProp}" onchange="submit();">
    <f:selectItem itemLabel="Zero" itemValue="0"/>
    <f:selectItem itemLabel="One" itemValue="1"/>
    <f:selectItem itemLabel="Two" itemValue="2"/>
    <f:selectItem itemLabel="Three" itemValue="3"/>
  </h:selectOneMenu>
</h:form>

Managed Bean snippet:

public void setMyProp(Long myProp) {
  this.myProp = myProp;
}

Any ideas?

Scott Fauerbach 


Mime
View raw message