myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Müllan" <bierbra...@gmail.com>
Subject Re: Integrating sandbox components with last stable version of myfaces
Date Mon, 16 Apr 2007 11:41:16 GMT
Yes, the last stable tomahwak version is 1.1.5 and you can not get any
kind of "last-stable-sandbox-release". So, if you take the
sandbox-version above, in combination with the 1.1.5 releases you
should be lucky without any NoClassDefFoundError.

Tom 1.1.5 is released and declared as stable, no 1.1.5 snapshot anymore.

cheers,

Gerald

On 4/16/07, Rudi Steiner <rudi.steiner@googlemail.com> wrote:
> Hi Gerald,
>
> the problem is, that taking this version of sandbox, I get the error
> described above. My question was, where I can get a sanbox-version
> compatible with the last official release of myfaces-impl and tomahawk
> (myfaces-impl-1.1.5.jar, tomahawk-1.1.3.jar).
>
> best regards,
> Rudi
>
> On 4/16/07, Gerald Müllan <bierbrauen@gmail.com> wrote:
> > Hi,
> >
> > have a look under:
> >
> > http://people.apache.org/builds/myfaces/nightly
> >
> > There are no official releases of sandbox - only snapshot builds -
> > since it works like a playground. Therefore it is not listed in the
> > download releases section.
> >
> > cheers,
> >
> > Gerald
> >
> > On 4/16/07, Rudi Steiner <rudi.steiner@googlemail.com> wrote:
> > > Hi Mike,
> > >
> > > thank you for your fast reply, but under this link I can't find
> > > something like sandbox.jar.
> > > Is this jar-File included in one of the jar-Files on this page?
> > >
> > > Rudi
> > >
> > > On 4/13/07, Mike Kienenberger <mkienenb@gmail.com> wrote:
> > > > Use Myfaces Core 1.1.5 and the Myfaces Tomahawk/Sandbox 1.1.5 release
> > > > candidate found here:
> > > >
> > > > http://people.apache.org/builds/myfaces/tomahawk-1.1.5/
> > > >
> > > >
> > > >
> > > > On 4/13/07, Rudi Steiner <rudi.steiner@googlemail.com> wrote:
> > > > > Hello,
> > > > >
> > > > > I set up a new project with myfaces-api-1.1.5.jar,
> > > > > myfaces-impl-1.1.5.jar, tomahawk-1.1.3.jar and everything works fine
> > > > > so far.
> > > > >
> > > > > Non I added tomahawk-sandbox-1.1.5-SNAPSHOT.jar from the nightly
> > > > > builds to test some sandbox components. The problem is, that I can't
> > > > > use the sandbox component but get this instead:
> > > > >
> > > > > java.lang.NoClassDefFoundError: org/apache/myfaces/custom/dojo/DojoWidget
> > > > >
> > > > > Googleing around I found, that "The dojo stuff was moved from
> > > > > sandbox to tom 3-4 weeks ago. So, the libraries should be found
> > > > > there." and realy, I found the class in the
> > > > > tomahawk-1.1.5-SNAPSHOT.jar.
> > > > >
> > > > > My problem is the following: I don't want to use snapshot-versions
of
> > > > > the myfaces-impl just to use the sandbox components but I woul'd
like
> > > > > to use the last stable versions of the myfaces- and tomahawk impl
> > > > > (myfaces-api-1.1.5.jar, myfaces-impl-1.1.5.jar, tomahawk-1.1.3.jar)
> > > > > plus the sandbox components (tomahawk-sandbox-1.1.5-SNAPSHOT.jar).
> > > > >
> > > > > Has anyone an idea, how I can get this combination up and running?
> > > > >
> > > > > Thank you,
> > > > > Rudi
> > > > >
> > > >
> > >
> >
> >
> > --
> > http://www.irian.at
> >
> > Your JSF powerhouse -
> > JSF Consulting, Development and
> > Courses in English and German
> >
> > Professional Support for Apache MyFaces
> >
>


-- 
http://www.irian.at

Your JSF powerhouse -
JSF Consulting, Development and
Courses in English and German

Professional Support for Apache MyFaces

Mime
View raw message