myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Kienenberger" <mkien...@gmail.com>
Subject Re: Does myfaces 1.1.5 nightly build require java 5 ?
Date Tue, 06 Feb 2007 18:23:44 GMT
Here's what a search turned up:

javac -source 1.4 -target 1.4 -bootclasspath /path/to/jre1.4/lib/rt.jar

You'd have to mavenize the command and put the correct directory in.
It'd probably be easier and faster to simply switch back to Java 1.4,
though.


On 2/6/07, Mike Kienenberger <mkienenb@gmail.com> wrote:
> We had the same problem with different method signatures between 1.4
> and 1.5 a few times in Cayenne.
>
> I think the solution is to set a boot classloader of some kind to
> point to the 1.4 jars when compiling, but I can't remember the
> details.
>
> On 2/6/07, Gerald Müllan <bierbrauen@gmail.com> wrote:
> > Hi,
> >
> > i have removed the jdk1.5 compliant expressions, should work now.
> > (svn-head)
> >
> > cheers,
> >
> > Gerald
> >
> > On 2/6/07, Adrian Mitev <adrian.mitev@googlemail.com> wrote:
> > > Hi all. I've just downloaded the nightly build. I run it under jboss with
> > > 1.4.2_11 jdk and i got this exception:
> > >
> > > ERROR [FacesConfigurator] failed to configure class
> > > org.apache.myfaces.custom.imageloop.HtmlImageLoopRenderer
> > > java.lang.NoSuchMethodError: java.lang.Integer.valueOf(I)Ljava/lang/Integer;
> > >         at
> > > org.apache.myfaces.custom.imageloop.HtmlImageLoopRenderer.<clinit>(HtmlImageLoopRenderer.java:44)
> > >         at
> > > sun.reflect.NativeConstructorAccessorImpl.newInstance0
> > > (Native Method)
> > >         at
> > > sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
> > >         at
> > > sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java
> > > :27)
> > >         at
> > > java.lang.reflect.Constructor.newInstance(Constructor.java:274)
> > >         at java.lang.Class.newInstance0(Class.java:308)
> > >         at java.lang.Class.newInstance(Class.java:261)
> > >
> > > As i see HtmlImageLoopRenderer uses method valueOf(int) that is not defined
> > > in jdk 1.4.2
> > >
> > >
> >
> >
> > --
> > http://www.irian.at
> >
> > Your JSF powerhouse -
> > JSF Consulting, Development and
> > Courses in English and German
> >
> > Professional Support for Apache MyFaces
> >
>

Mime
View raw message