myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Hedtfeld <stefan.hedtf...@xsoftahead.com>
Subject Re: [tobago] Upgrading from 1.0.8 to 1.0.9 breaks tc:link (solved)
Date Wed, 17 Jan 2007 20:53:51 GMT
Hello Bernd,

I tried the tobago example demo with the current trunk version and it
worked. So I tried with another web app of my own and it worked, too! I
finally found the significant difference in the two apps: I had an old
tobago-config.xml configuration in my new webapp, still pointing to
tobago and tobago-resource resource dirs. After changing to

  <resource-dir>org/apache/myfaces/tobago/renderkit</resource-dir>
  <resource-dir>tobago-resource</resource-dir>

everything works as expected (or as before!).

This corrects both cases: the "broken" links and the input field with
required markers. And you were right: the required markers were inside
my login screen: the login name and password fields ;-)

Thanks for your quick response.

Regards,

Stefan.

Bernd Bohmann schrieb:
> Hello Stefan,
>
> 1.0.9 has to many changes. May be you get a validation or conversion
> error. Can you send the page, please.
>
> There are some issue with the popup. I hope we sort this out with the
> 1.0.10 release. So far I know there is an problem with the required
> marker and autofill values from the browser like password field.
> Can you describe your case?
>
> Regards
>
> Bernd
>
> Stefan Hedtfeld wrote:
>> Hi,
>>
>> when upgrading my application from tobago 1.0.8 to 1.0.9 all my <tc:link
>> ...> tags fail to work. I didn't find any release notes where any issues
>> regarding upgrading from older versions are described.
>>
>> I'm running on JBoss 4.0.5 with JDK 1.5.0_10 and Firefox 2.0.
>>
>> I also noticed that the markers rendered to signal required fields keep
>> displayed when editing the fields (I recognised this with tx:in fields,
>> maybe it's also true for other controls).
>>
>> Regards,
>>
>> Stefan.
>>
>


Mime
View raw message