myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kamal Bhatt" <kbh...@tt.com.au>
Subject Re: t:messages - getting it to display the label
Date Sat, 11 Nov 2006 22:59:22 GMT
Weird typo. It is correct in my code. Sorry about that.

> Hi,
>
> is it just a typo? You have called the id of the input component
> "modelItinInpTxt" whereas
> the label points to "modelItin".
>
> regards,
>
> Gerald
>
> On 11/11/06, Kamal Bhatt <kbhatt@tt.com.au> wrote:
>> Hi
>> I may have posted this in the past, but I now have more details, so I
>> thought I would repost this query (it has gone unanswered for a while
>> now).
>>
>> I would like to use the facility in tomahawk's t:messages component that
>> prints the label in the messages. I have replaceIdWithLabel="true", and
>> I
>> have defined output labels for my component. For example:
>>  <t:messages id="test" replaceIdWithLabel="true"/>
>>  ...
>>    <t:outputLabel value="#{label.promotionSelectModelItin}"
>> for="modelItin"/>
>>    <t:inputText id="modelItinInpTxt"
>> value="#{promotionSelectPage.modelItin}">
>>      <t:validateRegExpr pattern="[A-Za-z0-9]{6,8}"
>>                        detailMessage="Invalid model itinerary"
>>                        summaryMessage="Invalid model itinerary"
>>                        message="Invalid model itinerary"/>
>>    </t:inputText>
>>
>> but I don't get any labels for my messages.
>>
>> I am using SJSAS 8.1 and sun RI.
>>
>>
>
>
> --
> http://www.irian.at
>
> Your JSF powerhouse -
> JSF Consulting, Development and
> Courses in English and German
>
> Professional Support for Apache MyFaces
>



Mime
View raw message