myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Volker Weber" <weber.vol...@googlemail.com>
Subject Re: Problem with websphere 6.1 and myfaces1.1.3
Date Wed, 06 Sep 2006 07:25:53 GMT
Hi,

the sun RI is included in the WS6.1!
IBM takes a lot of jars (jsf, many apache-common and other) and
repacked them into a single jar file, i don't remember the exact name,
something like webapp.jar ?.

Try to remove the api and impl jars from your webapp. Your (tobago)
app works without problems after doing that.

regards,

    Volker

2006/9/5, Nick77 <nickbaker77@gmail.com>:
>
> Hi,
>
> I also have this problem - have followed instructions to set up all the
> required jars from here
> http://wiki.apache.org/myfaces/Websphere_Installation
> http://wiki.apache.org/myfaces/Websphere_Installation  although as far as I
> can tell (ie by searching in the WS6.1 directory, there are no IBM JSF jars
> bundled with 6.1).
>
> I can successfully deploy the application, and no error messages are output
> to the log files, but the JSF components are simply not rendered.
>
> One thing that may be significant is that I do get the warning 'Unsupported
> component-family/renderer-type:
> <family-name>.<component-name>/javax.faces.Text' but I also get this when
> using JBoss and the app runs fine.
>
> Did you manage to solve this? And if so how?
>
> Thanks
>
> Nick
>
>
> pds wrote:
> >
> > Hi,
> >
> >  I am using myfaces1.1.3 in websphere6.1 .When deploying no exception is
> > occuring after I made the class-loader value as PARENTLAST.But the problem
> > is non of the jsf elements are rendering html content.Thats why my screen
> > is remaining blank.But my log statements are showing that its going
> > through all the phases of lifecycle.In websphere 6.0 this problem was not
> > occuring.
> >
> > Can anybody tell me what can be the problem  ?
> >
>
> --
> View this message in context: http://www.nabble.com/Problem-with-websphere-6.1-and-myfaces1.1.3-tf2163963.html#a6154547
> Sent from the MyFaces - Users forum at Nabble.com.
>
>

Mime
View raw message