myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Marin <the.ma...@free.fr>
Subject Re: Problem uploading files with Myfaces portlet
Date Tue, 04 Apr 2006 08:22:42 GMT
We stay with jetspeed but we are going to try the JBoss portal. Because thera
are problem with upload file, open popup, display pdf in a window browser, etc.
So there are to many problem !

I get a solution temporaly but not very nice because other parameter of the form
are not submitted. I use a multipart wrapper of cocoon. So i don't like that
solution... It would be very nice to assigned the bug to solve it. So in the
myfacesGenericPortlet, it is notice that the multipart aren't process.

if( !isMultipart...)
   process...

I use cocoon., And put the file in the session scope to process it.
BAD..BAD...BAD ... lol

-> Sébastien,
->
-> What do you use for JSF portlets? I also tried the Apache Portal's JSF
-> brdige and it has same problem.
->
-> Regards,
->
-> Raj
->
->
->
-> On 4/4/06, Sébastien Marin <the.marin@free.fr> wrote:
-> > We don't use the bridge and we have the same problem.
-> > So you can see the bug : http://issues.apache.org/jira/browse/TOMAHAWK-168
-> > We have just to wait...
-> >
-> >
-> > Selon Raj Saini <rajsaini@gmail.com>:
-> >
-> > -> Hi,
-> > ->
-> > -> I am using myfaces portlet for developing JSR-168 portlets with
-> > -> Jetspeed-2. I am facing problems while submitting a form for file
-> > -> uploading with enctype="multipart/form-data". With this encoding
-> > -> action method is not called. However, same application works fine, if
-> > -> I run it as standalone. This seems to be a bug in the portlet bridge.
-> > ->
-> > -> Is this a known problem?
-> > ->
-> > -> Regards,
-> > ->
-> > -> Raj

Mime
View raw message