myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jurgen Lust <Jurgen.L...@UGent.be>
Subject Re: [OT] Maven2 / Jetty (was Re: ExtensionsFilter + Jetty 6)
Date Tue, 21 Feb 2006 20:14:55 GMT
In fact, I posted the same message on the Jetty mailing list and I got 
an answer this afternoon by Jan Bartel of Mort Bay.
As it turns out it was a problem with the output handling in Jetty 6, 
and it should be fixed in the latest snapshot. I haven't verified it yet 
though.

Jurgen

Matthias Wessendorf schreef:
> Jurgen,
>
> I just did the same. Also, I am getting the same stack trace and the
> same blank page like you. Did you already get a chance to get this all
> runable ?
>
> -Matthias
>
> On 2/15/06, Jurgen Lust <Jurgen.Lust@ugent.be> wrote:
>   
>> I've tried with the SVN version of myfaces now, same problem.
>> You can verify this by adding this to the tomahawk/examples/simple/pom.xml:
>>
>>         <plugins>
>>             <plugin>
>>                 <groupId>org.mortbay.jetty</groupId>
>>                 <artifactId>maven-jetty6-plugin</artifactId>
>>                 <version>6.0.0beta9</version>
>>                 <configuration>
>>                     <scanIntervalSeconds>10</scanIntervalSeconds>
>>                 </configuration>
>>             </plugin>
>>         </plugins>
>>
>> And then typing mvn jetty6:run in the same folder.
>> Now you can access the simple example at
>> http://localhost:8080/myfaces-example-simple/
>> Normally you will now see a completely empty page...
>>
>> Kind regards,
>>
>> Jurgen
>>
>> Bruno Aranda schreef:
>>     
>>> Jurgen, can you post the stacktrace? Do you know if it worked before?
>>> There has been changes in the extensionsFilter lately which are
>>> causing some issues,
>>>
>>> Regards,
>>>
>>> Bruno
>>>
>>> On 2/14/06, Jurgen Lust <Jurgen.Lust@ugent.be> wrote:
>>>
>>>       
>>>> Hi,
>>>>
>>>> While trying the maven2 jetty6 plugin, I noticed that Jetty does not
>>>> render a JSF webpage when the ExtensionsFilter is loaded. The error I
>>>> get is "java.io.IOException: Closed".
>>>> Has anyone else had this problem, and if so, did you find a solution?
>>>>
>>>> Jurgen
>>>>
>>>>
>>>> --
>>>> Among flowers, the cherry blossom.
>>>> Among men, me.
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>         
>> --
>> Among flowers, the cherry blossom.
>> Among men, me.
>>
>>
>>
>>
>>     
>
>
> --
> Matthias Wessendorf
> Zülpicher Wall 12, 239
> 50674 Köln
> http://www.wessendorf.net
> mwessendorf-at-gmail-dot-com
>   


Mime
View raw message