myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michel Goldstein <michel.goldst...@gmail.com>
Subject AddResource issue
Date Sun, 08 Jan 2006 21:45:58 GMT
Hi,

I have been trying to figure out why none of my calls to
AddResource.addJavaScriptAtPosition(...,HEADER_BEGIN,...) are working.
There is no error in the logs, but simpley the <SCRIPT/> tag does not
appear on the generated html header.

I've done a lot of different tests and my latest bare-bones test is
the following:

1) I've deployed directly the myfaces-example-simple.war built from
the repositiory to my Tomcat server and it worked on a simple example
(tree2.jsf)
2) I've copied over to my project the jsp and the data bean
(TreeBacker.java), make the addition of this bean to my faces-config
file and it didn't work. No error messages, and no <SCRIPT/>

After my tests, I have two theories (that could be both wrong): I have
a configuration problem or a library conflict. I did remove most of
the libraries and tried to make sure that I understood all the
configuration differeces between the two projects, but it still didn't
work.

Does anybody know what could be going on here? Which package is
responsible for taking the attribute maps that are set in the
AddResource to generate the html response? Is there any configuration
in this package that could be causing this problem?

Thank you,
Michel

Mime
View raw message