myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CD <dcyphe...@gmail.com>
Subject Re: Popup calendar javascript - loadPopupScript not defined
Date Thu, 22 Dec 2005 20:17:23 GMT
Louis,

That is consistent with what I have done, what do your portlet.xml and
faces-config.xml look like?

Thanks!

Regards,
C. Dillon

On 12/22/05, Louis Burroughs <lburroug@aholdusa.com> wrote:
>
>
> I threw all the patterns I could think of ;)
>
>
>         <filter>
>                 <filter-name>extensionsFilter</filter-name>
>                 <filter-class>
>
> org.apache.myfaces.component.html.util.ExtensionsFilter
>                 </filter-class>
>                 <init-param>
>                         <param-name>uploadMaxFileSize</param-name>
>                         <param-value>100m</param-value>
>                 </init-param>
>                 <init-param>
>                         <param-name>uploadThresholdSize</param-name>
>                         <param-value>100k</param-value>
>                 </init-param>
>         </filter>
>         <filter-mapping>
>                 <filter-name>extensionsFilter</filter-name>
>                 <url-pattern>*.faces</url-pattern>
>         </filter-mapping>
>         <filter-mapping>
>                 <filter-name>extensionsFilter</filter-name>
>                 <url-pattern>/faces/*</url-pattern>
>         </filter-mapping>
>         <filter-mapping>
>                 <filter-name>extensionsFilter</filter-name>
>                 <url-pattern>*.jsf</url-pattern>
>         </filter-mapping>
>
>
>
>
> Louis M. Burroughs III
>
>
>   *CD <dcypher67@gmail.com>*
>
> 12/22/2005 02:58 PM
> Please respond to "MyFaces Discussion"
>
>
>
>         To:        MyFaces Discussion <users@myfaces.apache.org>
>         cc:
>         bcc:
>         Subject:        Re: Popup calendar javascript - loadPopupScript
> not defined
>
>
>
>
>
> Louis,
>
> Can you post some of the content of your config files where you set up the
> extensions filter?  That would be quite helpful.
>
>
> On 12/22/05, *Louis Burroughs* <*lburroug@aholdusa.com*<lburroug@aholdusa.com>>
> wrote:
> My extensions filter works (I think), for example my tree2 renders fine
> and all of the images from the jar show up.
>
> Do the scripts fail simply because the <script> tags are not in the
> <head>?  Or is there something more sinister at work?  If I can even get a
> general description of what needs to happen to get my scripts to function,
> I'll try to hack something to get it to work.
>
>
> Louis M. Burroughs III
>
>
>   *Martin Marinschek <**martin.marinschek@gmail.com *<martin.marinschek@gmail.com>
> *>*
>
> 12/22/2005 02:02 PM
> Please respond to "MyFaces Discussion"
>
>
>
>         To:        MyFaces Discussion <* users@myfaces.apache.org*<users@myfaces.apache.org>
> >
>         cc:
>         bcc:
>         Subject:        Re: Popup calendar javascript - loadPopupScript
> not defined
>
>
>
>
>
> You're in a portal environment?
>
> Well, this might as well be your problem. There are several known
> issues with the extension-filter and portlets, they boil down to the
> fact that the two don't work together ;)
>
> regards,
>
> Martin
>
> On 12/22/05, CD <* dcypher67@gmail.com* <dcypher67@gmail.com>> wrote:
> > Martin,
> >
> > I am encountering both as the resources and the javascript are not
> showing
> > up in the head.  I had modified my xmls (portlet, faces-config, and web)
> to
> > represent how I thought they should be configured for MyFaces but I
> > encountered a ClassCastException in the container that involved IBM's
> > WebSphere WebApp.  My environment once again is WebSphere Portal   v5.1.
> > Don't know that it would be beneficial for me to to send the content of
> the
> > config files in this thread, though I do think it would help.  What
> would be
> > the best way of posting this information as I think I am just incapable
> of
> > configuring it properly :)
> >
> >
> >
> >
> > On 12/22/05, Martin Marinschek <* martin.marinschek@gmail.com*<martin.marinschek@gmail.com>>
wrote:
> > > To come back to Kurt's and CDs original problem -
> > >
> > > Kurt - your header is rendered correctly - can you fire up something
> > > like HTTPFiddler and check if the files are actually delivered to your
>
> > > browser?
> > >
> > > Next step - start your app in debugging mode, attach the
> > > myfaces-sources to the jar-file, and debug into ExtensionsFilter?
> > >
> > > CD - do you have the same issue as Kurt - no resources being
> > > delivered, or is your head not showing the additional scripts?
> > >
> > > regards,
> > >
> > > Martin
> > >
> > > On 12/22/05, Martin Marinschek < * martin.marinschek@gmail.com*<martin.marinschek@gmail.com>>
> wrote:
> > > > Sounds good to me!
> > > >
> > > > this also bears documentation with it ;)
> > > >
> > > > regards,
> > > >
> > > > Martin
> > > >
> > > > On 12/21/05, Mike Kienenberger < *mkienenb@gmail.com*<mkienenb@gmail.com>>
wrote:
> > > > > On 12/21/05, Simon Kitching < *skitching@obsidium.com*<skitching@obsidium.com>>
> wrote:
> > > > > > > <!-- extension mapping for serving page-independent
resources
> > > > > > > (javascript, stylesheets, images, etc.)  -->
> > > > > > > <filter-mapping>
> > > > > > >
> > <filter-name>MyFacesExtensionsFilter</filter-name>
> > > > > > >     <url-pattern>/faces/*</ url-pattern>
> > > > > > > </filter-mapping>
> > > > > > >
> > > > > >
> > > > > > I liked your suggestion of mapping this to
> > > > > >    /faces/myFacesExtensionResource/*
> > > > > >
> > > > > > This mapping is what I use in the app I'm currently developing,
> and
> > it
> > > > > > works fine. Is there a reason you changed your mind?
> > > > >
> > > > > As I mentioned on the dev list, I couldn't get it to work!
> > > > >
> > > > > As soon as I switched from /faces/* to
> > > > > /faces/myFacesExtensionResource/*, the buttons on my
> > popup
> > > > > t:inputCalendar components stopped drawing.
> > > > >
> > > > > Strangely enough, I tried it yet again, and now it's working.
>  Guess
> > > > > it must have been user error on my part.  I think maybe what
> happened
> > > > > is that I broke the other piece (my web.xml uses "FacesServlet"
> while
> > > > > MyFaces docs and examples have "Faces Servlet") and didn't notice
> the
> > > > > difference until after I stopped trying to use
> > > > > /faces/myFacesExtensionResource/*
> > > > >
> > > > > I'm +1 for changing it to
> > /faces/myFacesExtensionResource/*  since
> > > > > you've been using that successfully.
> > > > >
> > > >
> > > >
> > > > --
> > > >
> > > > *http://www.irian.at * <http://www.irian.at/>
> > > >
> > > > Your JSF powerhouse -
> > > > JSF Consulting, Development and
> > > > Courses in English and German
> > > >
> > > > Professional Support for Apache MyFaces
> > > >
> > >
> > >
> > > --
> > >
> > > *http://www.irian.at* <http://www.irian.at/>
> > >
> > > Your JSF powerhouse -
> > > JSF Consulting, Development and
> > > Courses in English and German
> > >
> > > Professional Support for Apache MyFaces
> > >
> >
> >
>
>
> --
>
> *http://www.irian.at* <http://www.irian.at/>
>
> Your JSF powerhouse -
> JSF Consulting, Development and
> Courses in English and German
>
> Professional Support for Apache MyFaces
>
>
>

Mime
View raw message