myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexandre Poitras <alexandre.poit...@gmail.com>
Subject Re: Navigation Panel 2 error
Date Tue, 06 Dec 2005 21:20:06 GMT
It's already fixed in the nightly build :)  Guess someone else has found it
before me.

On 12/6/05, Mike Kienenberger <mkienenb@gmail.com> wrote:
>
> That's lame.   If you open a JIRA issue with a patch, I'll be sure to
> commit it.
>
> On 12/6/05, Alexandre Poitras <alexandre.poitras@gmail.com> wrote:
> > Ok I found the error. The default renderkit is
> org.apache.myfaces.Navigation
> > in the class.
> > The jsp tag overwrite it with
> > org.apache.myfaces.NavigationMenu but since I'm using
> > another view technology I end up with the default one.
> >
> >
> > On 12/6/05, Mike Kienenberger <mkienenb@gmail.com> wrote:
> > > The component.xml files are leftovers from the days of code
> > > generation.    They're currently unused in MyFaces, so it's unlikely
> > > to be the cause of your problem.
> > >
> > > On 12/6/05, Alexandre Poitras < alexandre.poitras@gmail.com> wrote:
> > > > Whoops I mean there are no xml files at all in the package so it is
> > probably
> > > > why it doesn't work.....
> > > >
> > > >
> > > > On 12/6/05, Alexandre Poitras < alexandre.poitras@gmail.com> wrote:
> > > > > I think there's a bug in the HtmlPanelNavigation.xml , because the
> > > > component class is
> > > >
> > org.apache.myfaces.custom.navigation.HtmlPanelNavigation
> > > > and it should be
> > > > >
> > > >
> > org.apache.myfaces.custom.navmenu.htmlnavmenu.HtmlPanelNavigationMenu
> > > > . Anyone have noticed this bug before?
> > > > >
> > > > >
> > > > >
> > > > > On 12/6/05, Alexandre Poitras < alexandre.poitras@gmail.com>
> wrote:
> > > > > > I am trying to use the Navigation Panel 2
> > > >
> > (org.apache.myfaces.custom.navmenu.htmlnavmenu.HtmlPanelNavigationMenu
> > > > ) and I receive the following error.
> > > > > > [Class:
> > > >
> > org.apache.myfaces.custom.navmenu.htmlnavmenu.HtmlPanelNavigationMenu
> > > > ,Id: nav2]} is not instance of
> > > >
> > org.apache.myfaces.custom.navigation.HtmlPanelNavigation as
> > > > it should be
> > > > > >
> > > > > >
> > > > > > Anyone have an idea of what I am doing wrong?
> > > > > > --
> > > > > > Alexandre Poitras
> > > > > > Québec, Canada
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Alexandre Poitras
> > > > > Québec, Canada
> > > >
> > > >
> > > >
> > > > --
> > > > Alexandre Poitras
> > > > Québec, Canada
> > >
> >
> >
> >
> > --
> > Alexandre Poitras
> > Québec, Canada
>



--
Alexandre Poitras
Québec, Canada

Mime
View raw message