myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "CONNER, BRENDAN \(SBCSI\)" <bc1...@sbc.com>
Subject RE: Problem while deploying in IBM WebSpher Application Server 5.1
Date Fri, 28 Oct 2005 19:08:57 GMT
We have not run into problems with the jsp-2.0.jar file, but we also don't use PARENT_LAST.
 Let us know what you find with that combination. ;-)

- Brendan

-----Original Message-----
From: Eric Hedström [mailto:erich@ucsd.edu] 
Sent: Friday, October 28, 2005 1:04 PM
To: MyFaces Discussion
Subject: Re: Problem while deploying in IBM WebSpher Application Server 5.1


Have you run into any problems bundling jsp-2.0.jar in a jsp-1.2 
container like WebSphere 5.1? We are leery of doing this because (due to 
some other jar version conflicts with WebSphere) we have to run our web 
app with the classloader set to PARENT_LAST.

On 27 Oct 2005 8:32, CONNER, BRENDAN (SBCSI) wrote:

> We have the following JARs in our lib directory (in a working WebSphere 
> environment):
>  
> commons-beanutils-1.6.1.jar
> commons-codec-1.2.jar
> commons-collections-3.0.jar
> commons-digester-1.5.jar
> commons-el.jar
> commons-fileupload-1.0.jar
> commons-lang-2.1.jar
> commons-validator.jar
> jaxen-full.jar
> jsp-2.0.jar
> jstl_el.jar
> jstl.jar
> myfaces-api.jar
> myfaces-impl.jar
> saxpath.jar
> standard.jar
> struts.jar (for Tiles)
> tomahawk.jar
>  
> BTW, awhile back, we were putting myfaces-wap.jar and 
> myfaces-xdoclet.jar into our lib directory.  Are these still used?
>  
> - Brendan
>  
> -----Original Message-----
> *From:* Anjaneyulu Sadineni [mailto:sadinenia@gmail.com]
> *Sent:* Thursday, October 27, 2005 10:00 AM
> *To:* MyFaces Discussion
> *Subject:* Re: Problem while deploying in IBM WebSpher Application 
> Server 5.1
> 
>     Hi,
>       We didn't have jsp-api.jar in lib dir. Do we need to have
>     jsp-api.jar in lib dir ..?
>      
>     Thanks
> 
> 
>      
>     On 10/27/05, *rosalba bochicchio* <rosalba_2001@yahoo.it
>     <mailto:rosalba_2001@yahoo.it>> wrote:
> 
>         Did you include jsp-api.jar in your lib?
> 
>         --- Anjaneyulu Sadineni < sadinenia@gmail.com
>         <mailto:sadinenia@gmail.com>> wrote:
> 
>          > Dear Ryan,
>          >  Thanks for ur reply. We are using My Faces and
>          > tomahawk only. We have the
>          > following JSF related jars in class path.
>          >  Myfaces-impl.jar , myfaces-api.jar, tomahawk.jar .
>          >    Thanks
>          >
>          >
>          >
>          >  On 10/26/05, Ryan Wynn <rwynn@us.ibm.com
>         <mailto:rwynn@us.ibm.com>> wrote:
>          > >
>          > >
>          > > What type of jsf configuration are you trying to
>          > support? Only MyFaces,
>          > > reference impl. + tomahawk, any of the ibm-jsf
>          > stuff? I have had problems
>          > > with some of the combinations.
>          > >
>          > > For example, when I tried reference impl. +
>          > tomahawk I could not start the
>          > > web app because the faces-config parser was trying
>          > to go out to the internet
>          > > and retrieve a reference to something in the
>          > tomahawk faces-config.xml . It
>          > > couldn't find it so the application wouldn't
>          > start. This only happened when
>          > > using the reference impl. MyFaces across the board
>          > did not go after this
>          > > reference.
>          > >
>          > > If you could please list the jsf related jars in
>          > your classpath.
>          > >
>          > >
>          > >
>          > >
>          > >   *"CONNER, BRENDAN \(SBCSI\)" < bc1378@sbc.com
>         <mailto:bc1378@sbc.com> >*
>          > >
>          > > 10/26/2005 02:39 PM   Please respond to
>          > > "MyFaces Discussion"
>          > >
>          > >    To
>          > > "MyFaces Discussion" < users@myfaces.apache.org
>         <mailto:users@myfaces.apache.org> >
>          > cc
>          > >   Subject
>          > > RE: Problem while deploying in IBM WebSpher
>          > Application Server 5.1
>          > >
>          > >
>          > >
>          > >
>          > > There should be no conflicts as log as you don't
>          > include IBM's JSF JAR
>          > > files in your EAR.
>          > >
>          > > - Brendan
>          > > -----Original Message-----*
>          > > From:* Anjaneyulu Sadineni [mailto:
>          > sadinenia@gmail.com <mailto:sadinenia@gmail.com>] *
>          > > Sent:* Wednesday, October 26, 2005 1:34 PM*
>          > > To:* MyFaces Discussion*
>          > > Subject:* Problem while deploying in IBM WebSpher
>          > Application Server 5.1
>          > >
>          > > Hi,
>          > > We have been using my faces in our application and
>          > it is working fine in
>          > > TOMCAT 5.0. But, We are not able to deploy same
>          > war file in IBM WebSpher
>          > > Application Server 5.1. We are getting the
>          > following msg
>          > > as "Application falied to Intialize" and then the
>          > server is getting
>          > > stopped .
>          > > But when we remove the myfaces-impl.jar from war
>          > file, we are able to
>          > > deploy it. Is there any conflicts ere between
>          > myfaces-impl.jar and IBM
>          > > jars ?.Please let us know if u have any idea on
>          > this Problem.
>          > >
>          > > Advance thanks for ur help.
>          > >
>          > > Thanks
>          > >
>          >
> 
> 
> 
> 
> 
>         __________________________________
>         Yahoo! Mail - PC Magazine Editors' Choice 2005
>         http://mail.yahoo.com
> 
> 

Mime
View raw message