myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francesco Consumi <cons...@istitutodeglinnocenti.it>
Subject Upgrading problem
Date Tue, 20 Sep 2005 06:36:52 GMT
Hi all,

I'm trying to upgrade my projects from myfaces 1.0.9 to 1.1.0.
I replaced myfaces.jar with myfaces-all.jar, updated project references 
to that file and
replaced <%@ taglib uri="http://myfaces.apache.org/extensions" prefix="x"%>
with <%@ taglib uri="http://myfaces.apache.org/tomahawk" prefix="t"%>

and <x:/> with <t:/>

but I obtain an error:
(<t:panelLayout> is the first jsf component in page, except <f:view>....)

javax.faces.FacesException: Undefined component type 
org.apache.myfaces.HtmlPanelLayout
       at
org.apache.myfaces.application.ApplicationImpl.createComponent(ApplicationImpl.java:390)
       at
javax.faces.webapp.UIComponentTag.createComponentInstance(UIComponentTag.java:448)
       at 
javax.faces.webapp.UIComponentTag.findComponent(UIComponentTag.java:391)
       at javax.faces.webapp.UIComponentTag.doStartTag(UIComponentTag.java:219)
       at 
org.apache.jsp.login_jsp._jspx_meth_t_panelLayout_0(login_jsp.java:263)
       at org.apache.jsp.login_jsp._jspx_meth_f_view_0(login_jsp.java:229)



some suggestion ? thanks....

-- 
Francesco Consumi
Ufficio Sistemi informativi
Istituto degli Innocenti
Piazza SS.Annunziata, 12
50122 Firenze
consumi at istitutodeglinnocenti.it
Tel. +39 055 2037320
ICQ# 12516133



Mime
View raw message