myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Belisle <Nicolas.Beli...@bibl.ulaval.ca>
Subject commandSortHeader issue
Date Mon, 15 Aug 2005 16:16:37 GMT
Hi,

I just want to report an issue I'm having with the <t:commandSortHeader/>
component.

When I use JSF RI 1.1. the arrows do not display. The same page correctly
displays in MyFaces (1.09).

I've also tried the nightly build (14-Aug-2005) of Tomahawk.

Here's the dataTable :

<x:dataTable id="deposits"
          value="#{examinationBean.deposits.dataModel}"
          var="deposit"
          sortColumn="#{examinationBean.deposits.sortColumn}"
          sortAscending="#{examinationBean.deposits.ascending}">
          <h:column>
                  <f:facet name="header">
                          <x:commandSortHeader columnName="title" arrow="true">
                                  <f:verbatim>Header</f:verbatim>
                          </x:commandSortHeader>
                  </f:facet>

                  <f:verbatim>ATitle</f:verbatim>
                  <h:commandLink action="#{examinationBean.toOne}">
                          <f:verbatim>//seeMe</f:verbatim>
                  </h:commandLink>
          </h:column>
</x:dataTable>


Something I might do wrong or it looks like a JIRA candidate ?


* Also, I ran into a couple of issues trying to run the Myfaces-examples
with JSF RI 1.1. Anyone having success on this ?


Regards,

Nicolas 


Mime
View raw message