myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Marinschek <martin.marinsc...@gmail.com>
Subject Re: AW: Error w/o JSF-API.JAR
Date Wed, 25 May 2005 11:43:59 GMT
If you want to use plain vanilla MyFaces, you just need the
myfaces.jar - that's all.

your error message points to some remnaints of the reference
implementation somewhere in your/tomcat working directory.

regards,

Martin

On 5/25/05, alex <desperados_23@yahoo.co.nz> wrote:
> Rene Guenther wrote:
> 
> >Do I really have to add all of them:
> >myfaces-impl.jar
> >AND myfaces-jsf-api.jar
> >AND myfaces-extensions.jar
> >AND myfaces.jar
> >
> >Do I still need jsf-impl.jar then?
> >
> >Thanks
> >Rene
> >
> >
> I'm not sure about the myfaces.jar, however, I think myfaces-impl.jar is
> a replacement for jsf-impl.jar of sun, such as myfaces-jsf-api.jar is a
> replacement for the jsf-api.jar of sun.
> you need the myfaces-extensions.jar if you want to use compontents like
> x:datatable and other things provided by myfaces.
> 
> I would recommend that you delete jsf-impl.jar from sun either from your
> classpath. It could mess up things for the myfaces-extensions.
> 
> Rgds
> Alex
>

Mime
View raw message