myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Wahlforss <e...@wahlforss.com>
Subject MyFaces tiles problem
Date Fri, 18 Mar 2005 23:55:32 GMT
hi,
I have problems getting tiles to work properly with myfaces. The 
problems occur when i try to use forms in nested tiles. When i press 
the submit button in the form, the browser just reloads the page with 
'nothing' being executed on the server.
I end up with an empty template being shown without any database data 
in it etc. not a single error message in the log, nothing..very 
strange. I've tried many different setups in the faces-navigation file 
and nothing works, not even static actions (that are not bound to 
methods on backing beans). this is the way the important part of the 
navigation file looks now:

         <navigation-case>
           
<from-action>#{entryPageBean.createCommentAction}</from-action>
           <from-outcome>createComment</from-outcome>
           <to-view-id>/createComment.tiles</to-view-id>
         </navigation-case>

the tiles config is just:

     <definition name=".mainLayout" 
path="/WEB-INF/templates/layout.jspx">
         <put name="head" value="/WEB-INF/tiles/head.jspx"/>
	<put name="header" value="/WEB-INF/tiles/header.jspx"/>
	<put name="navigation" value="/WEB-INF/tiles/navigation.jspx"/>
	<put name="ads" value="/WEB-INF/tiles/ads.jspx"/>
	<put name="footer" value="/WEB-INF/tiles/footer.jspx"/>
     </definition>

and for the entry page where the action gets executed:

     <definition name="/entry.tiles" extends=".mainLayout" >
	<put name="title" value="Entry Page"/>
         <put name="body" value="/WEB-INF/tiles/entry.jspx"/>
     </definition>

I'm using tomcat 5.0, myfaces 1.0.9rc1 (same result with 1.0.8), jspx 
(jsp:s with xml-syntax), firefox on mac os x..
I've checked the list-archives and noticed that some other people had 
similar problems, but there seem to be no solution as of yet..? Looks 
like I'll have to give up using tiles, which is a pity since the 
integration in myfaces is pretty nice..
any ideas on why it doesn't work...?

bests // eric

--------------------------------------------
Eric Wahlforss
http://eric.wahlforss.com/
eric@wahlforss.com
+46 70 363 99 00
jabber: ericwahlforss@jabber.cn
skype, aim: ericwahlforss
--------------------------------------------


Mime
View raw message