myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Eric Miller" <jemil...@uchicago.edu>
Subject Re: Validation Errors Inconsistent
Date Wed, 09 Mar 2005 21:53:05 GMT
Another issue that I noticed is that if the user enters a file name/path 
that doesn't exist, it submits OK, but, the file length is 0. Ideally, the 
renderer would check for a 0 length file and throw a validation error.

Jon

----- Original Message ----- 
From: "Jonathan Eric Miller" <jemiller@uchicago.edu>
To: "MyFaces Discussion" <myfaces-user@incubator.apache.org>
Sent: Wednesday, March 09, 2005 3:43 PM
Subject: Re: Validation Errors Inconsistent


>I just tested this on a form that I have and it seems to work OK as far as 
>the error messages go. However, if there is a validation error, the text 
>box part of the file upload control is blanked out. But, if I view the HTML 
>source, I can see that the value is correctly set to the file name. So, I'm 
>guessing this is a browser bug? The problem happens with the latest IE and 
>Firebird browsers for Windows XP.
>
> Jon
>
> ----- Original Message ----- 
> From: "Srikanth Madarapu" <srikanthm@senior-systems.com>
> To: "MyFaces Discussion" <myfaces-user@incubator.apache.org>
> Sent: Wednesday, March 09, 2005 9:22 AM
> Subject: RE: Validation Errors Inconsistent
>
>
>> There must be some error occurring behind the scenes. May be in your file 
>> handling. I have seen such behavior sometimes, look in the log files. Or 
>> it may be related some other issue.
>>
>> -----Original Message-----
>> From: mfaine [mailto:mfaine@knology.net]
>> Sent: Wednesday, March 09, 2005 10:18 AM
>> To: MyFaces Discussion
>> Subject: Validation Errors Inconsistent
>>
>>
>> Myfaces 1.0.8
>> Tomcat 5.0.28
>>
>> I have a page with an x:inputFileUpload tag and a number of other 
>> associated
>> h:inputField tags.  Many of the inputField tags are required as is the
>> inputFileUpload tag but strangely I only get validation error messages 
>> when
>> the inputFileUpload has been populated.  It is as if the other fields 
>> depend
>> on that field to be populated before they are even processed.
>>
>> If I select a file using the browse button then attempt to submit an
>> incomplete form I get all the proper validation error messages for every
>> incomplete field, if I leave the inputFileUpload box blank the page 
>> merely
>> resets itself with no validation error messages.
>>
>> Any idea what is causing this?
>>
>> Thanks,
>> -Mark
>>
>>
> 


Mime
View raw message