myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Grzegorz Grzybek (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Commented] (MYFACES-4262) MyFaces 2.3 should import correct javax.servlet packages in OSGi
Date Tue, 06 Nov 2018 13:26:03 GMT

    [ https://issues.apache.org/jira/browse/MYFACES-4262?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16676758#comment-16676758
] 

Grzegorz Grzybek commented on MYFACES-4262:
-------------------------------------------

[~tandraschko], please tell me - is "[3,5)" version range ok for servlet API? I don't think
we should use servlet api below 3.

> MyFaces 2.3 should import correct javax.servlet packages in OSGi
> ----------------------------------------------------------------
>
>                 Key: MYFACES-4262
>                 URL: https://issues.apache.org/jira/browse/MYFACES-4262
>             Project: MyFaces Core
>          Issue Type: Bug
>          Components: JSR-372
>    Affects Versions: 2.3.2
>            Reporter: Grzegorz Grzybek
>            Priority: Major
>             Fix For: 2.3.3, 3.0.0-SNAPSHOT
>
>
> After fixing MYFACES-4141 with [this commit|https://github.com/apache/myfaces/commit/731e40cdb4ce5d336192b705c070e3c0f8175305],
where servlet-api dependency was set to tomcat-servlet-api:9.0.2, myfaces-bundle should use
correct imports of OSGi packages.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message