myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Commented] (TOBAGO-1902) Migrate to jQuery 3
Date Thu, 21 Jun 2018 13:50:00 GMT

    [ https://issues.apache.org/jira/browse/TOBAGO-1902?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16519385#comment-16519385
] 

Hudson commented on TOBAGO-1902:
--------------------------------

SUCCESS: Integrated in Jenkins build Tobago 3.0.x #51 (See [https://builds.apache.org/job/Tobago%203.0.x/51/])
TOBAGO-1902: Migrate to jQuery 3 (lofwyr: rev fc3056e299a9de5ec6ac1cdd1b97a852bd220691)
* (delete) tobago-theme/tobago-theme-standard/src/main/resources/META-INF/resources/tobago/standard/jquery/jquery-2.2.4.js
* (edit) tobago-theme/tobago-theme-standard/src/main/resources/META-INF/tobago-config.xml
* (delete) tobago-theme/tobago-theme-standard/src/main/resources/META-INF/resources/tobago/standard/jquery/jquery-2.2.4.min.map
* (delete) tobago-theme/tobago-theme-standard/src/main/resources/META-INF/resources/tobago/standard/jquery/jquery-2.2.4.min.js


> Migrate to jQuery 3
> -------------------
>
>                 Key: TOBAGO-1902
>                 URL: https://issues.apache.org/jira/browse/TOBAGO-1902
>             Project: MyFaces Tobago
>          Issue Type: Task
>          Components: Themes
>    Affects Versions: 3.0.6, 2.1.1, 4.2.1
>            Reporter: Udo Schnurpfeil
>            Assignee: Udo Schnurpfeil
>            Priority: Major
>             Fix For: 3.1.0, 4.3.0
>
>
> We should switch to jQuery 3 to be up-to-date with the current development. The browser
support is 9+ for Internet Explorer and "last + current" for the other browsers (like jQuery
2).
> Tobago 2.x (which currently uses jQuery 1) supports older IE browsers, it might me a
solution to render jQuery 1 for IE 8 and jQuery 3 for IE 9.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message