myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Andraschko (JIRA)" <>
Subject [jira] [Commented] (MYFACES-4163) h:commandScript execute attribute does not have a default value
Date Fri, 13 Oct 2017 11:45:00 GMT


Thomas Andraschko commented on MYFACES-4163:

[~werpu] Could have a look at the commandScript? The ajax request itself works fine, also
the action on the server side is executed but the firefox console gives this error:
getAttributeNode() sollte nicht mehr verwendet werden. Verwenden Sie stattdessen getAttribute().


TypeError: this._Dom is undefined

> h:commandScript execute attribute does not have a default value
> ---------------------------------------------------------------
>                 Key: MYFACES-4163
>                 URL:
>             Project: MyFaces Core
>          Issue Type: Bug
>    Affects Versions: 2.3.0-beta
>            Reporter: Jay Sartoris
>            Assignee: Thomas Andraschko
>            Priority: Minor
>             Fix For: 2.3.0
>         Attachments: CommandScript.war
> The vdldoc for the h:commandScript component state that "@this" should be the default
value for the "execute" attribute. 
> The excerpt from the execute attribute description in vdldocs/facelets/h/commandScript.html
> -------
> This is a space separated list of client identifiers of components that will participate
in the "execute" portion of the Request Processing Lifecycle. If a literal is specified the
identifiers must be space delimited. Any of the keywords "@this", "@form", "@all", "@none"
may be specified in the identifier list. *If not specified, the default value of "@this" is
assumed.* For example, @this clientIdOne clientIdTwo.
> -------
> When I specify the component like this (without an execute attribute):
> {code:java}
> <h:form id="form1">
>     <h:commandScript name="commandScript1" action="#{commandScriptBean.testCommandScript('success')}"
render=":output1" autorun="true"/>
> </h:form>
> <h:outputText id="output1" value="MyFaces test output: #{commandScriptBean.output}"
> {code}
> I receive the following exception:
> {noformat}
>  java.lang.NullPointerException
> 	at org.apache.myfaces.renderkit.html.HtmlCommandScriptRenderer.getCollectionFromSpaceSplitString(
> 	at org.apache.myfaces.renderkit.html.HtmlCommandScriptRenderer.encodeBegin(
> 	at javax.faces.component.UIComponentBase.encodeBegin(
> 	at javax.faces.component.UIComponentBase.encodeAll(
> 	at javax.faces.component.UIComponentBase.encodeAll(
> 	at javax.faces.component.UIComponentBase.encodeAll(
> 	at javax.faces.component.UIComponentBase.encodeAll(
> 	at org.apache.myfaces.view.facelets.FaceletViewDeclarationLanguage.renderView(
> 	at org.apache.myfaces.application.ViewHandlerImpl.renderView(
> 	at javax.faces.application.ViewHandlerWrapper.renderView(
> 	at org.apache.myfaces.lifecycle.RenderResponseExecutor.execute(
> 	at org.apache.myfaces.lifecycle.LifecycleImpl.render(
> 	at javax.faces.webapp.FacesServlet.service(
> {noformat}
> When I try the same example using the Mojarra RI, it works as expected.  
> I tried this with the MyFaces 2.3.0-beta and also several snapshots however, the issue
still occurs.  The latest snapshot I tried was the 20171010.124738-264 version of the impl.
> I will upload a sample application to help reproduce the issue.  

This message was sent by Atlassian JIRA

View raw message