myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Beikov (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Created] (MYFACES-4161) Component in facet not relocated in composite component
Date Sun, 08 Oct 2017 13:04:00 GMT
Christian Beikov created MYFACES-4161:
-----------------------------------------

             Summary: Component in facet not relocated in composite component
                 Key: MYFACES-4161
                 URL: https://issues.apache.org/jira/browse/MYFACES-4161
             Project: MyFaces Core
          Issue Type: Bug
    Affects Versions: 2.2.10
            Reporter: Christian Beikov


I have a composite component that accepts a facet. The composite component defines a form
within which the facet is rendered. It roughly looks like this

{code:xml}
<composite:interface>
  <composite:facet name="before" />
</composite:interface>
<composite:implementation>
  <h:form>
    ...
    <composite:renderFacet name="before"/>
    ...
  </h:form>
</composite:implementation>
{code:xml}

Now when I use an input component in the facet, it doesn't get relocated into the appropriate
naming container.

{code:xml}
<my:component>
  <f:facet name="before">
    <h:inputText .../>
  </f:facet>
</my:component>
{code:xml}

The client id of the input element does not contain the form id and is thus not being considered
during form processing.
Can you confirm this is a bug?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message