myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Werner Punz (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Commented] (EXTSCRIPT-188) Extension don't works on Myfaces 2.2.3 / 2.2.11
Date Mon, 13 Feb 2017 12:30:41 GMT

    [ https://issues.apache.org/jira/browse/EXTSCRIPT-188?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15863578#comment-15863578
] 

Werner Punz commented on EXTSCRIPT-188:
---------------------------------------

Currently working should by MyFaces  2.0.x and 2.1.x. I have explicitely tested the demos
at the last release
with MyFaces 2.1.7 at the time of release (which was the latest version by then). MyFaces
2.0.x also should work.

You might also be able to use it in the latest version of MyFaces 2.1.x (I doubt Leo did a
lot of changes in the Bean infrastructure on the 2.1.x branch, since it already was in maintenance,
but it for now wont work for MyFaces 2.2.x, you have to wait for the new release for that
one which will come sometime in the March April timeframe. Also atm, it wont compile on Java
8. that also will be fixed (there are some Scala related issues with the java 8 compiler,
I probably will drop Scala in the long run and only keep Groovy and Java as dynamic compile
targets.)

PS: I am glad some people use this stuff, I thought the project did not have any community
at all, and thought seriously about putting it into the attic. So this gives me an incentive
to revive it again. Sorry that it has been on a hiatus for so long.

> Extension don't works on Myfaces 2.2.3 / 2.2.11
> -----------------------------------------------
>
>                 Key: EXTSCRIPT-188
>                 URL: https://issues.apache.org/jira/browse/EXTSCRIPT-188
>             Project: MyFaces Extensions Scripting
>          Issue Type: Bug
>          Components: MyFaces 2.0 Extension
>    Affects Versions: 1.0.6-FINAL
>         Environment: Debian 8.2
> JDK 1.8
> Tomcat 7.0.42
>            Reporter: NCister
>            Assignee: Werner Punz
>
> Trying to follow example config (http://myfaces.apache.org/extensions/scripting/exampleconfig.html)
I've noticed that the web.xml settings are wrong so:
> <param-name>org.apache.myfaces.FACES_INIT_PLUGINS</param-name>
> <param-value>org.apache.myfaces.extensions.scripting.servlet.StartupServletContextPluginChainLoader</param-value>
> must be updated to:
> ...
> <param-value>org.apache.myfaces.extensions.scripting.jsf.startup.StartupServletContextPluginChainLoader</param-value>
> ...
> Again: The example war (https://repository.apache.org/content/repositories/releases/org/apache/myfaces/extensions/scripting/myfaces20-extscript-helloworld/1.0.5/myfaces20-extscript-helloworld-1.0.5.war)
deployed in a clean tomcat 7.0 instance) don't works (no errors, no results ...)
> Does Groovy integration works in MyFaces 2.2 ?
> Thanks.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message