myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leonardo Uribe (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Commented] (MYFACES-4005) Classloading conflict with httpclient (update commons-codec to 1.10)
Date Tue, 14 Jul 2015 22:25:05 GMT

    [ https://issues.apache.org/jira/browse/MYFACES-4005?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14627160#comment-14627160
] 

Leonardo Uribe commented on MYFACES-4005:
-----------------------------------------

I think the best solution is use maven-shade-plugin to bundle commons-coded inside myfaces-impl
and mark the dependency as optional in the pom.xml. It is too late at this moment to update
commons-codec in 2.2 branch so this is something to do for 2.3.

> Classloading conflict with httpclient (update commons-codec to 1.10)
> --------------------------------------------------------------------
>
>                 Key: MYFACES-4005
>                 URL: https://issues.apache.org/jira/browse/MYFACES-4005
>             Project: MyFaces Core
>          Issue Type: Task
>            Reporter: Thomas Andraschko
>            Assignee: Leonardo Uribe
>
> To avoid problems like:
> http://stackoverflow.com/questions/7688644/java-lang-nosuchmethoderror-org-apache-commons-codec-binary-base64-encodebase64
> when e.g. httpclient is also used in the application (which imports a newer version).
> Source:
> /core/trunk/parent/pom.xml
> Line 497
> I could also provide an patch but should be the same effort to commit.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message