myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Krashan Brahmanjara (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Created] (MYFACES-3898) Response returns multiple <?xml version='1.0' encoding='utf-8'?> headers
Date Thu, 29 May 2014 09:42:07 GMT
Krashan Brahmanjara created MYFACES-3898:
--------------------------------------------

             Summary: Response returns multiple <?xml version='1.0' encoding='utf-8'?>
headers
                 Key: MYFACES-3898
                 URL: https://issues.apache.org/jira/browse/MYFACES-3898
             Project: MyFaces Core
          Issue Type: Bug
    Affects Versions: 2.2.3, 2.2.4-SNAPSHOT
            Reporter: Krashan Brahmanjara


For complex pages Myfaces implemetation return response with many xml headers. This is not
problem for Firefox but Internet Explorer sometimes cant render this pages and show it as
plain xml

Current Myfaces response example:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html>
<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?>
<html xmlns="http://www.w3.org/1999/xhtml"><head><link (...)

This problem doesn't occurs for Mojarra implementation.
This implementation returns response :
?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE HTML>
<html xmlns="http://www.w3.org/1999/xhtml"><head><link href=(...)



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message