myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Udo Schnurpfeil (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Created] (TOBAGO-1236) Naming concept for setting id/clientId in on-the-fly generated components
Date Sat, 02 Mar 2013 07:07:14 GMT
Udo Schnurpfeil created TOBAGO-1236:
---------------------------------------

             Summary: Naming concept for setting id/clientId in on-the-fly generated components
                 Key: TOBAGO-1236
                 URL: https://issues.apache.org/jira/browse/TOBAGO-1236
             Project: MyFaces Tobago
          Issue Type: Improvement
            Reporter: Udo Schnurpfeil
            Assignee: Udo Schnurpfeil


Some component renderer are creating "sub components" on-the-fly.
Often is helps, when they use fixed names for the ids, to make the DOM easier to read, test,
etc.

The problem is, when the component is not a UINamingContainer, we will get a duplicate id
exception.

One solution may to define a generating concept like: prefix + const + id_from_main_component:
e.g.: _t_next-button_sheet

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message