myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Kienenberger <mkien...@gmail.com>
Subject Re: servlet-3.0
Date Sat, 17 Nov 2012 00:07:00 GMT
Well, if servlet 3.1 is the minimum requirement, then I think we
should go with at least 3.0 rather than using a soft or optional
dependency.



On Fri, Nov 16, 2012 at 7:04 PM, Mark Struberg <struberg@yahoo.de> wrote:
> JSF-2.2 will be part of EE-7 thus servlet-3.1 even.
>
>
> It's currently used in a few components in myfaces-shared.
>
> Not sure where else we would need it. Probably for async-supported if we like to implement
that.
>
>
> LieGrue,
> strub
>
>
>
> ----- Original Message -----
>> From: Mike Kienenberger <mkienenb@gmail.com>
>> To: MyFaces Development <dev@myfaces.apache.org>; Mark Struberg <struberg@yahoo.de>
>> Cc:
>> Sent: Saturday, November 17, 2012 12:52 AM
>> Subject: Re: servlet-3.0
>>
>> What is the spec requirements for 2.2?   If 2.2 doesn't insist on
>> servlet-3.0, then I'd make it a soft dependency rather than a hard
>> failure.
>>
>>
>> On Fri, Nov 16, 2012 at 5:10 PM, Mark Struberg <struberg@yahoo.de> wrote:
>>>
>>>
>>>  Thanks Thomas, sounds reasonable. Though there is still myfaces-2.1.x which
>> runs perfectly fine with only servlet-2.5
>>>
>>>
>>>  This is really only required for JSF-2.2. Now I personally assume that
>> people start using JSF-2.2 in production around Q3 next year (2013). And until
>> then I hope that all people who really are eager to use JSF-2.2 moved on to
>> servlet-3.0 already ;)
>>>
>>>
>>>  Not sure about big banks, etc which still use EE5 containers and upgraded
>> 'manually' (placing myfaces into WARs). But those companies will switch
>> to JSF-2.2 earliest 2014 and I'm not exactly sure what we can expect then.
>> Most probably all users/customers are on EE6 then at least.
>>>
>>>
>>>  LieGrue,
>>>  strub
>>>
>>>
>>>
>>>
>>>> ________________________________
>>>>  From: Thomas Andraschko <andraschko.thomas@gmail.com>
>>>> To: MyFaces Development <dev@myfaces.apache.org>; Mark Struberg
>> <struberg@yahoo.de>
>>>> Sent: Friday, November 16, 2012 10:37 PM
>>>> Subject: Re: servlet-3.0
>>>>
>>>>
>>>> Hi,
>>>>
>>>> i think it would be better for many users to still support 2.5 and only
>> require 3.0 for the htmlInputFileRenderer.
>>>> Many users already use other fileuploads like PrimeFaces and don't
>> need this.
>>>>
>>>> Regards,
>>>> Thomas
>>>>
>>>>
>>>> 2012/11/16 Mark Struberg <struberg@yahoo.de>
>>>>
>>>> Hi folks!
>>>>>
>>>>> We did lots of tricks to keep core free of servlet-3.0. But sadly we
>> leak it in MyFaces-2.2 due to myfaces-shared HtmlInputFileRenderer.
>>>>> This function requires the multi MIME Part which is new in
>> servlet-3.0.
>>>>>
>>>>> That means servlet-2.5 support is only guaranteed if you don't
>> use that feature.
>>>>>
>>>>> How do we treat this? Require servlet-3.0 for mf-2.2 or let it crash
>> and write up a note about it?
>>>>>
>>>>> LieGrue,
>>>>> strub
>>>>>
>>>>
>>>>
>>>>
>>

Mime
View raw message