myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leonardo Uribe (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Commented] (MYFACES-3649) myfaces-shaded-impl always unpacks myfaces-2.1.1
Date Fri, 16 Nov 2012 17:42:12 GMT

    [ https://issues.apache.org/jira/browse/MYFACES-3649?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13498960#comment-13498960
] 

Leonardo Uribe commented on MYFACES-3649:
-----------------------------------------

I remember implee6 module was created to ensure JSF 2.0 code to be JDK 1.5 compatible. See
this thread:

http://markmail.org/message/dfwi4eaay4iammox

I have no objections to get rid of it in 2.1.x branch, because JSF 2.1 is JDK6 compatible.
In fact, in some point of the time the original plan was to integrate it again with impl module.
                
> myfaces-shaded-impl always unpacks myfaces-2.1.1
> ------------------------------------------------
>
>                 Key: MYFACES-3649
>                 URL: https://issues.apache.org/jira/browse/MYFACES-3649
>             Project: MyFaces Core
>          Issue Type: Bug
>          Components: build process
>    Affects Versions: 2.2.0, 2.1.9, 2.1.10
>            Reporter: Mark Struberg
>            Assignee: Mark Struberg
>            Priority: Blocker
>         Attachments: myfaces-3649.patch
>
>
> myfaces-shared-impl hardcoded unpacks mf-2.1.1 right now. How can this work?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message