myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ertio Lew (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Commented] (MYFACES-3464) Using Myfaces 2.1.6 does not allow to using a user provided EL (e.g. jBoss-el) other than what is provided by container when used with Webesphere 7 .
Date Mon, 20 Aug 2012 12:50:38 GMT

    [ https://issues.apache.org/jira/browse/MYFACES-3464?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13437831#comment-13437831
] 

Ertio Lew commented on MYFACES-3464:
------------------------------------

Similar problem in my case too. I tried replacing default EL impl with Juel 2.2.5 while using
Myfaces 2.1.8. While there were no error messages in the logs but I saw that Myfaces was still
using default impl. Had follwoing message in logs:
INFO: MyFaces Unified EL support enabled

I already included required stuff in web.xml & pom. On Switching to Mojarra 2.1.3 the
default impl was easily overridden by Juel. I tried with Myfaces, on Glassfish & tomcat
both but same message(above) in both the cases.
                
> Using Myfaces 2.1.6 does not allow to using a user provided EL (e.g. jBoss-el) other
than what is provided by container when used with Webesphere 7 .
> -----------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MYFACES-3464
>                 URL: https://issues.apache.org/jira/browse/MYFACES-3464
>             Project: MyFaces Core
>          Issue Type: Bug
>    Affects Versions: 2.1.6
>         Environment: Websphere 7.0.0.17  
> JSF 2
>            Reporter: Shahzeb Khan
>            Assignee: Leonardo Uribe
>
> There seems to be no way to use an EL other than what is provided by Websphere (have
not checked with any other server).
> We are using JSF 2 via isolated shared library with Websphere  version 7.0.0.17. Trying
to use jBoss-el by adding it to the isolated shared libraries or to lib directory and setting

>  <context-param>
>         <param-name>org.apache.myfaces.EXPRESSION_FACTORY</param-name>
>         <param-value>org.jboss.el.ExpressionFactoryImpl</param-value>
>     </context-param>
> in web.xml does not make myfaces pickup the supplied EL.
> In the logs this line is written [13/02/12 15:19:06:113 EST] 00000029 ExternalSpeci I
  MyFaces Unified EL support disabled.
> tracked it down to this method org.apache.myfaces.util.ExternalSpecifications#isUnifiedELAvailable()
. The try block throws a error as can not find class ( and method but exception is thrown
at the first check i.e class) and catch block sets the return value to false. This stopping
it to use an externally supplied EL . 
> I have also asked this question on SO
> http://stackoverflow.com/questions/9091354/how-can-i-update-websphere-7-to-use-el2-2

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message