myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott O'Bryan <darkar...@gmail.com>
Subject Move Trinidad Trunk to JSF 2.1
Date Sun, 25 Mar 2012 16:17:35 GMT
Hey all,

Currently the Trinidad Trunk is set to JSF 2.0.  There have been a 
number of blocker bugs recently (namely some issues with the 
ViewDeclarationLanguages and composite components) which have generated 
some blocking bugs.  These problems were cause by additional methods in 
the ViewDeclarationLanguage syntax which we have to wrap for some of the 
functionality in Trinidad to be complete.

At this time I propose the following:

1. Copy the current Trinidad Trunk to be branches/trinidad-2.0.x
2. Change the version of Trinidad Trunk to be 2.1.0-SNAPSHOT
3. Change the JSF dependency for trunk to be MyFaces 2.1
4. Change the trinidad plugins trunk to be 2.1.0 for consistency.
5. Change both branches/trinidad-2.0.x and trunk to use the new trinidad 
plugins snapshot.

I'm hoping everyone will agree to this so that we can fix some of the 
blocker issues we've had show up after the the last Trinidad release.  
Many of which seem to be JSF 2.1 related.

Please respond to this email with a +1 or a -1 and don't forget to 
include any any reasons why you do not wish to support the move.

Thanks,
   Scott

Mime
View raw message