myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Udo Schnurpfeil (Created) (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Created] (TOBAGO-1093) The attribute to set the label for tc:selectBooleanCheckbox should be named as "itemLabel" instead of "label"
Date Wed, 15 Feb 2012 13:34:59 GMT
The attribute to set the label for tc:selectBooleanCheckbox should be named as "itemLabel"
instead of "label"
-------------------------------------------------------------------------------------------------------------

                 Key: TOBAGO-1093
                 URL: https://issues.apache.org/jira/browse/TOBAGO-1093
             Project: MyFaces Tobago
          Issue Type: Task
    Affects Versions: 1.5.3
            Reporter: Udo Schnurpfeil
            Assignee: Udo Schnurpfeil
            Priority: Minor


This change make the two tag tc:selectBooleanCheckbox and  tx:selectBooleanCheckbox more consistent.
The tx tag uses the itemLabel attribute to set the label in the checkbox itself.
In sum we have 3 label to keep consistent:
1. the tobago tx label which was rendered separatly from the component
2. the label of the component
3. the JSF label attribute which is be shown in faces error messages.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message