myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paweł Mączka (Created) (JIRA) <...@myfaces.apache.org>
Subject [jira] [Created] (TRINIDAD-2195) xmlMenuModel - itemNode with attribute 'rendered' set to boolean 'false' with EL still rendered
Date Sat, 07 Jan 2012 18:01:39 GMT
xmlMenuModel - itemNode with attribute 'rendered' set to boolean 'false' with EL still rendered
-----------------------------------------------------------------------------------------------

                 Key: TRINIDAD-2195
                 URL: https://issues.apache.org/jira/browse/TRINIDAD-2195
             Project: MyFaces Trinidad
          Issue Type: Bug
          Components: Components
    Affects Versions: 2.0.0-core
         Environment: myfaces 2.1.5 or 2.0.5; tomcat 6 or 7
            Reporter: Paweł Mączka


itemNode is rendered when attribute value for rendered = false with EL. When set to 'false'
in xml - it is not rendered.
I tried with almost everything as value including: rendered="#{request.userInRole['admin']
eq true}" 
Also created a managed bean with simple method: 
public boolean getRendered(){ return false; 	}
and put it into label and rendered attribute. In label attribute I can see 'false' so the
value is used but the node is still rendered which is a bug for me.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message