myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Werner Punz (Issue Comment Edited) (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Issue Comment Edited] (MYFACES-3422) f:ajax execute="@all" ist not processing all forms on the page
Date Fri, 16 Dec 2011 10:36:30 GMT

    [ https://issues.apache.org/jira/browse/MYFACES-3422?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13170889#comment-13170889
] 

Werner Punz edited comment on MYFACES-3422 at 12/16/11 10:36 AM:
-----------------------------------------------------------------

Ok you are right: the JSF 2.1 Spec section 14.2.2 states following:
@all ... all component identifiers
@form ... only the enclosing form

Since @all needs to be passed down to the server the issue. The @all is definitely sent.
Guess the server side guys now have to take over here.



                
      was (Author: werpu):
    Ok you are right: the JSF 2.1 Spec section 14.2.2 states following:
@all ... all component identifiers
@form ... only the enclosing form

Since @all needs to be passed down to the server the issue currently is that the surrounding
form identifier is sent instead as it seems. So the issue clearly is on my side. I need to
sync  with Leo, if we have an @all handling on the server side.


                  
> f:ajax execute="@all" ist not processing all forms on the page
> --------------------------------------------------------------
>
>                 Key: MYFACES-3422
>                 URL: https://issues.apache.org/jira/browse/MYFACES-3422
>             Project: MyFaces Core
>          Issue Type: Bug
>    Affects Versions: 2.1.5
>            Reporter: Michael Dietrich
>         Attachments: MyFaces215AjaxTest.war
>
>
> Hi,
> according to our understanding, setting execute="@all" for a f:ajax tag should submit
and process entries of all forms on the page, instead of submitting only entries of the surroundig
form, if execute="@form" is set. Unfortunately, this seems not to work. I attached a small
project to reproduce the issue.
> Kind regards,
> Michael

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message