myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Udo Schnurpfeil (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Commented] (EXTCDI-198) Support for Java 1.5 (needed for WebSphere 6.1)
Date Mon, 22 Aug 2011 19:12:29 GMT

    [ https://issues.apache.org/jira/browse/EXTCDI-198?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13088939#comment-13088939
] 

Udo Schnurpfeil commented on EXTCDI-198:
----------------------------------------

I've also tested it successfully with Java 1.5.0_19 and Tomcat 5.5.33.

> Support for Java 1.5 (needed for WebSphere 6.1)
> -----------------------------------------------
>
>                 Key: EXTCDI-198
>                 URL: https://issues.apache.org/jira/browse/EXTCDI-198
>             Project: MyFaces CODI
>          Issue Type: Improvement
>          Components: Core
>    Affects Versions: 1.0.0
>            Reporter: Udo Schnurpfeil
>            Assignee: Gerhard Petracek
>             Fix For: 1.0.1
>
>
> I would be nice, if CODI supports Java 1.5, e. g. to run with WebSphere 6.1.
> It can be implemented with low effort.
> There is one basic dependency to Java 1.6: java.util.ServiceLoader
> To solve this problem, I've added a utility class in my local copy and delegate calls
to ServiceLoader to this utility.
> The utility class itself calls ServiceLoader, if the class is available (Java 1.6) or
uses com.googlecode.bspi.ServiceLoader (Java 1.5).
> So the application needs one new dependency (only in the case of Java 1.5).
> The maven-compiler-plugin still generates Java 1.5 compatible byte code.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message