myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James G (JIRA)" <...@myfaces.apache.org>
Subject [jira] [Commented] (MYFACES-3131) jsf.js:tables not rendering after ajax call in internet explorer 6
Date Mon, 09 May 2011 20:10:03 GMT

    [ https://issues.apache.org/jira/browse/MYFACES-3131?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13030880#comment-13030880
] 

James G commented on MYFACES-3131:
----------------------------------

Thanks for fixing this!!

> jsf.js:tables not rendering after ajax call in internet explorer 6
> ------------------------------------------------------------------
>
>                 Key: MYFACES-3131
>                 URL: https://issues.apache.org/jira/browse/MYFACES-3131
>             Project: MyFaces Core
>          Issue Type: Bug
>    Affects Versions: 2.0.5
>         Environment: Tomcat 6 / Myfaces 2.0.5 and Richfaces 4.0.0.Final
> Internet Explorer 6 as client
>            Reporter: James G
>             Fix For: 2.0.6-SNAPSHOT, 2.1.0-SNAPSHOT
>
>
> objects that start with <table> disappear when they are selected for render during
an ajax call.
> I debugged the problem and found it occurs in the _outerHTMLNonCompliant function.  When
tagName is "table", _buildTableNodes is called (it really shouldn't be called in this case).
> In _buildTableNodes, dummyPlaceHolder.innerHTML is set to "<table><table>STUFF</table></table>".
> ie6 changes this to "<table><tbody></tbody><table>STUFF</table></table>"
so evalNodes is set to the empty tbody and thus the table sent back from the server is lost.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message