myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Halbig (JIRA)" <...@myfaces.apache.org>
Subject [jira] Updated: (MYFACES-2959) Version 1.1.8 not compatible using JSP 1.2 because of using apache commons-el 1.0
Date Fri, 18 Feb 2011 13:37:43 GMT

     [ https://issues.apache.org/jira/browse/MYFACES-2959?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andreas Halbig updated MYFACES-2959:
------------------------------------

    Status: Open  (was: Patch Available)

> Version 1.1.8 not compatible using JSP 1.2 because of using apache commons-el 1.0
> ---------------------------------------------------------------------------------
>
>                 Key: MYFACES-2959
>                 URL: https://issues.apache.org/jira/browse/MYFACES-2959
>             Project: MyFaces Core
>          Issue Type: Bug
>          Components: General
>    Affects Versions: 1.1.8
>         Environment: SAP NetWeaver J2EE Engine 7.0 (WebAs Java)
>            Reporter: Andreas Halbig
>            Priority: Blocker
>   Original Estimate: 2h
>  Remaining Estimate: 2h
>
> According to the requirement specifrication, MyFaces 1.1 is supposed to support java
1.3 or later, JSP 1.2, JSTL 1.0, and a Java Servlet 2.3 implementation. Unfortunately, the
FacesConfigurator is using the javax.servlet.jsp.el package, which is only available since
JSP 2.0.
> Following classes to use wrongly javax.servlet.jsp.el.
> - org.apache.myfaces.shared_impl.util.ClassUtils
> - org.apache.myfaces.shared_impl.util._Coercions
> - org.apache.myfaces.config.ManagedBeanBuilder
> - org.apache.myfaces.el.ELParserHelper
> - org.apache.myfaces.el.MethodBindingImpl
> - org.apache.myfaces.el.ValueBindingImpl
> Issue is related to the fact, that the apache commons-el 1.0 package is used, which requires
the JSP 2.0 interfaces. This issue can be solved by reworking in two ways
> 1) Rework the interfaces for commons-el to remove the dependency for JSP 2.0
> 2) or by Adding the missing classes manually. You need to remove the annotations within
the source code and compile it using Java 1.3
> - ELException
> - Expression
> - ExpressionEvalutator
> - FunctionMapper
> - VariableResolver
> The corresponding exception thrown within my j2ee container below
> Error occured in invoking event "contextInitialized()" on listener class org.apache.myfaces.webapp.StartupServletContextListener.
The error is: java.lang.NoClassDefFoundError: javax/servlet/jsp/el/ELException
> 	at org.apache.myfaces.config.FacesConfigurator.feedStandardConfig(FacesConfigurator.java:308)
> 	at org.apache.myfaces.config.FacesConfigurator.configure(FacesConfigurator.java:276)
> 	at org.apache.myfaces.webapp.StartupServletContextListener.initFaces(StartupServletContextListener.java:82)
> 	at org.apache.myfaces.webapp.StartupServletContextListener.contextInitialized(StartupServletContextListener.java:65)
> 	at com.sap.engine.services.servlets_jsp.server.runtime.context.WebEvents.contextInitialized(WebEvents.java:45)
> 	at com.sap.engine.services.servlets_jsp.server.container.ApplicationThreadInitializer.run(ApplicationThreadInitializer.java:112)
> 	at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)
> 	at java.security.AccessController.doPrivileged(Native Method)
> 	at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:104)
> 	at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:176)

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message