myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kennard Consulting (JIRA)" <...@myfaces.apache.org>
Subject [jira] Commented: (TOMAHAWK-1560) Tomahawk 1.1.10 for JSF 1.2 fails to deploy on JBoss AS 6 because of TLD errors
Date Tue, 11 Jan 2011 23:34:47 GMT

    [ https://issues.apache.org/jira/browse/TOMAHAWK-1560?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12980434#action_12980434
] 

Kennard Consulting commented on TOMAHAWK-1560:
----------------------------------------------

Stan,

Thanks for your time in looking at this.

Your suggestion does not appear to have any effect. Even with both 'useSchemaValidation' and
'useValidation' set to false, the error is the same...

Caused by: org.jboss.xb.binding.JBossXBRuntimeException: -1:-1 -1:-1 schema_reference.4: Failed
to read schema document 'null', because 1) could not find the document; 2) the document could
not be read; 3) the root element of the document is not <xsd:schema>.
        at org.jboss.xb.binding.sunday.unmarshalling.XsdBinderTerminatingErrorHandler.handleError(XsdBinderTerminatingErrorHandler.java:40)
[jbossxb.jar:2.0.3.GA]
        at org.apache.xerces.impl.xs.XMLSchemaLoader.reportDOMFatalError(Unknown Source) [xercesImpl.jar:6.0.0.Final]
        at org.apache.xerces.impl.xs.XSLoaderImpl.load(Unknown Source) [xercesImpl.jar:6.0.0.Final]
        at org.jboss.xb.binding.Util.loadSchema(Util.java:394) [jbossxb.jar:2.0.3.GA]
        at org.jboss.xb.binding.sunday.unmarshalling.XsdBinder.bind(XsdBinder.java:178) [jbossxb.jar:2.0.3.GA]
        at org.jboss.xb.binding.sunday.unmarshalling.XsdBinder.bind(XsdBinder.java:149) [jbossxb.jar:2.0.3.GA]
        at org.jboss.xb.binding.resolver.AbstractMutableSchemaResolver.resolve(AbstractMutableSchemaResolver.java:342)
[jbossxb.jar:2.0.3.GA]
        ... 72 more

...this is perhaps a little surprising, but maybe JBoss is trying to load the schema even
though it has been told not to use it? If I remove the "TldParsingDeployer" bean altogether
from war-deployers-jboss-beans.xml then there is no error (but presumably things will fail
at a later stage).

Regards,

Richard.

> Tomahawk 1.1.10 for JSF 1.2 fails to deploy on JBoss AS 6 because of TLD errors
> -------------------------------------------------------------------------------
>
>                 Key: TOMAHAWK-1560
>                 URL: https://issues.apache.org/jira/browse/TOMAHAWK-1560
>             Project: MyFaces Tomahawk
>          Issue Type: Bug
>    Affects Versions: 1.1.10
>            Reporter: Kennard Consulting
>            Priority: Critical
>         Attachments: TOMAHAWK-1560.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> Tomahawk 1.1.10 for JSF 1.2 fails to deploy on the recently released JBoss AS 6. This
appears to be because of errors in tomahawk.tld. I managed to resolve it by taking the following
steps (any of which may be sub-optimal):
> 1. Changed xsi:schemaLocation="http://java.sun.com/xml/ns/javaee/web-jsptaglibrary_2_1.xsd"
to xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-jsptaglibrary_2_1.xsd"
(i.e. the first half of the schemaLocation was missing)
> 2. Removed <display-name> tag (is a bad element name?)
> 3. Removed all <description> tags (they contain invalid markup?)
> Regards,
> Richard.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message