myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Kaltepoth (JIRA)" <...@myfaces.apache.org>
Subject [jira] Commented: (TOMAHAWK-1560) Tomahawk 1.1.10 for JSF 1.2 fails to deploy on JBoss AS 6 because of TLD errors
Date Wed, 12 Jan 2011 06:31:48 GMT

    [ https://issues.apache.org/jira/browse/TOMAHAWK-1560?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12980584#action_12980584
] 

Christian Kaltepoth commented on TOMAHAWK-1560:
-----------------------------------------------

Here is a link to the JBoss issue that Stan created regarding this:

https://issues.jboss.org/browse/JBAS-8800

However, I think that this issue should also be fixed in the Trinidad/Tomahawk/Commons TLDs.
It is undeniable that the current TLDs are not readable by a validating parser because they
do not validate against the schema. And that is something that should be fixed for future
versions.

> Tomahawk 1.1.10 for JSF 1.2 fails to deploy on JBoss AS 6 because of TLD errors
> -------------------------------------------------------------------------------
>
>                 Key: TOMAHAWK-1560
>                 URL: https://issues.apache.org/jira/browse/TOMAHAWK-1560
>             Project: MyFaces Tomahawk
>          Issue Type: Bug
>    Affects Versions: 1.1.10
>            Reporter: Kennard Consulting
>            Priority: Critical
>         Attachments: TOMAHAWK-1560.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> Tomahawk 1.1.10 for JSF 1.2 fails to deploy on the recently released JBoss AS 6. This
appears to be because of errors in tomahawk.tld. I managed to resolve it by taking the following
steps (any of which may be sub-optimal):
> 1. Changed xsi:schemaLocation="http://java.sun.com/xml/ns/javaee/web-jsptaglibrary_2_1.xsd"
to xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-jsptaglibrary_2_1.xsd"
(i.e. the first half of the schemaLocation was missing)
> 2. Removed <display-name> tag (is a bad element name?)
> 3. Removed all <description> tags (they contain invalid markup?)
> Regards,
> Richard.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message