myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kennard Consulting (JIRA)" <...@myfaces.apache.org>
Subject [jira] Commented: (MYFACES-3010) 2.0.3 REGRESSION: javax.faces.component._ClassUtils.convertToType
Date Mon, 10 Jan 2011 22:37:51 GMT

    [ https://issues.apache.org/jira/browse/MYFACES-3010?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12979820#action_12979820
] 

Kennard Consulting commented on MYFACES-3010:
---------------------------------------------

The IllegalArgumentException is below. Note it appears to be specific to my app, but does
not occur with previous versions of MyFaces (2.0.2, JSF 1.2 and JSF 1.1) or with Mojarra:

javax.faces.FacesException: java.lang.IllegalArgumentException: Cannot convert Personal of
type class org.metawidget.example.shared.addressbook.model.ContactType$1 to class org.metawidget.example.shared.addressbook.model.ContactType$2
	at org.apache.myfaces.shared_impl.context.ExceptionHandlerImpl.wrap(ExceptionHandlerImpl.java:241)
	at org.apache.myfaces.shared_impl.context.ExceptionHandlerImpl.handle(ExceptionHandlerImpl.java:156)
	at org.apache.myfaces.lifecycle.LifecycleImpl.executePhase(LifecycleImpl.java:191)
	at org.apache.myfaces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:118)
	at javax.faces.webapp.FacesServlet.service(FacesServlet.java:189)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
	at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.IllegalArgumentException: Cannot convert Personal of type class org.metawidget.example.shared.addressbook.model.ContactType$1
to class org.metawidget.example.shared.addressbook.model.ContactType$2
	at org.apache.el.lang.ELSupport.coerceToType(ELSupport.java:375)
	at org.apache.el.ExpressionFactoryImpl.coerceToType(ExpressionFactoryImpl.java:46)
	at javax.faces.component._ClassUtils.convertToType(_ClassUtils.java:337)
	at javax.faces.component._SelectItemsUtil._convertOrCoerceValue(_SelectItemsUtil.java:133)
	at javax.faces.component._SelectItemsUtil.matchValue(_SelectItemsUtil.java:65)
	at javax.faces.component.UISelectOne.validateValue(UISelectOne.java:77)
	at javax.faces.component.UIInput.validate(UIInput.java:583)
	at javax.faces.component.UIInput.processValidators(UIInput.java:247)
	at javax.faces.component.UIComponentBase.processValidators(UIComponentBase.java:1218)
	at javax.faces.component.UIForm.processValidators(UIForm.java:147)
	at javax.faces.component.UIComponentBase.processValidators(UIComponentBase.java:1218)
	at javax.faces.component.UIViewRoot._processValidatorsDefault(UIViewRoot.java:1322)
	at javax.faces.component.UIViewRoot.access$500(UIViewRoot.java:75)
	at javax.faces.component.UIViewRoot$ProcessValidatorPhaseProcessor.process(UIViewRoot.java:1397)
	at javax.faces.component.UIViewRoot._process(UIViewRoot.java:1278)
	at javax.faces.component.UIViewRoot.processValidators(UIViewRoot.java:754)
	at org.apache.myfaces.lifecycle.ProcessValidationsExecutor.execute(ProcessValidationsExecutor.java:34)
	at org.apache.myfaces.lifecycle.LifecycleImpl.executePhase(LifecycleImpl.java:171)
	... 14 more


> 2.0.3 REGRESSION: javax.faces.component._ClassUtils.convertToType
> -----------------------------------------------------------------
>
>                 Key: MYFACES-3010
>                 URL: https://issues.apache.org/jira/browse/MYFACES-3010
>             Project: MyFaces Core
>          Issue Type: Bug
>          Components: General
>    Affects Versions: 2.0.3
>            Reporter: Kennard Consulting
>            Priority: Critical
>         Attachments: addressbook-faces2.zip
>
>
> Hi guys,
> Thanks again for the great work you do on MyFaces and your fantastic JIRA response times!
> I attach a small app that comes from the Metawidget (http://metawidget.org) distribution.
I had you do MYFACES-2935 for me for MyFaces 2.0.3, and my app was working great with the
2.0.3-impl-SNAPSHOT.jar and the 2.0.2-api.jar. However now that 2.0.3 is out for real I have
tried to upgrade my app, and it fails. To reproduce, please:
> 1. Unzip the attached app and deploy as an exploded WAR into Tomcat
> 2. Run Tomcat and hit http://localhost:8080/addressbook-faces2
> 3. In the Type dropdown, choose 'Business' and click Search
> You will see an IllegalArgumentException. Now:
> 4. Stop Tomcat
> 5. Inside the exploded WAR, rename myfaces-api-2.0.2.rename.me to myfaces-api-2.0.2.jar
(and delete/rename myfaces-api-2.0.3.jar)
> 6. Restart Tomcat and repeat steps 1-3
> This time you will see no such error.
> So something appears to have broken between myfaces-api-2.0.2.jar and myfaces-api-2.0.3.jar?
Hopefully you can reproduce this and it is enough for you to debug the issue. The source code
for the small app can be viewed here:
> http://metawidget.svn.sourceforge.net/viewvc/metawidget/trunk/examples/src/java/org/metawidget/example/faces/addressbook/
> http://metawidget.svn.sourceforge.net/viewvc/metawidget/trunk/examples/src/java/org/metawidget/example/shared/addressbook/
> Of course, this could well be a case of 2.0.3 being stricter about something and therefore
exposing a bug in my code. But my code worked in 2.0.2, JSF 1.2 and JSF 1.1, so hopefully
not!
> Regards,
> Richard

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message