myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject require-bundle header in api bundle
Date Fri, 05 Nov 2010 18:02:00 GMT
I'm trying to understand why the require-bundle header is in the api bundle.  This is a pretty
bizarre thing to do in what I've seen of osgi.

I took it out and geronimo-tomcat appears to work OK.  Maybe because this is because geronimo
has a somewhat extended thread context classloader, but maybe not.

I saw some vague claims in the comments to MYFACES-2911 that the api classes need to load
impl classes, but no details.  Could someone point me to the code where this happens?  There
must be a better way to do this....

thanks
david jencks


Mime
View raw message