myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Weßendorf (JIRA) <...@myfaces.apache.org>
Subject [jira] Commented: (MYFACES-2911) OSGi Manifest: MyFaces API Bundle requires IMPL Bundle
Date Tue, 07 Sep 2010 06:20:33 GMT

    [ https://issues.apache.org/jira/browse/MYFACES-2911?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12906686#action_12906686
] 

Matthias Weßendorf commented on MYFACES-2911:
---------------------------------------------

Yes, API and IMPL are somewhat tied - I am sure the RI api has same "requirement"

Thx for updating the patch

> OSGi Manifest: MyFaces API Bundle requires IMPL Bundle
> ------------------------------------------------------
>
>                 Key: MYFACES-2911
>                 URL: https://issues.apache.org/jira/browse/MYFACES-2911
>             Project: MyFaces Core
>          Issue Type: Bug
>          Components: General
>         Environment: OSGi container
>            Reporter: Frank Mittag
>            Priority: Minor
>
> The MANIFEST.MF file of the org.apache.myfaces.core.api bundle/jar contains the entry:
> Require-Bundle: org.apache.myfaces.core.impl;bundle-version="2.0.1" 
> So the API bundle requires the IMPL bundle to work. This is not needed and prevents scenarios
where the e.g. two IMPL bundles just reference the same API bundle.
> The easiest solution is just to remove the entry.
> Frank

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message