myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jakob Korherr <jakob.korh...@gmail.com>
Subject Re: [core] commons-beanutils level
Date Tue, 20 Jul 2010 13:58:39 GMT
Hi Michael,

I don't think there is a real reason why this was not updated. We just
"forgot" to do it.

Also this seems very promising: "BeanUtils 1.8.x releases are binary
compatible with version 1.7.0 and require a minimum of JDK 1.3." Thus I
don't think there should be problems.

Regards,
Jakob

2010/7/20 Michael Concini <mconcini@gmail.com>

>  Is there any reason we can't update our beanutils dependency to the latest
> level (1.8.3)?  There is a memory leak during app undeploy that one of our
> customers has run into that is resolved in moving from 1.7.0 to 1.8.0 by
> BEANUTILS-156 <https://issues.apache.org/jira/browse/BEANUTILS-156>.  I'd
> like to move up to the latest however if we update, or at least to 1.8.1, as
> the original fix looks to have exposed a second problem that is later
> resolved in BEANUTILS-347<https://issues.apache.org/jira/browse/BEANUTILS-347>.
> Plus if we're going to move up we might as well move to the latest since
> they're binary compatible.
>
> If there are no objections, I'll go ahead and open up a JIRA issue to
> update the poms for the current 1.2 and 2.0 releases.  I just wanted to make
> sure there wasn't any reason we were still dependent on the 1.7.0 release
> before I made the change.
>
> Regards,
> Mike
>



-- 
Jakob Korherr

blog: http://www.jakobk.com
twitter: http://twitter.com/jakobkorherr
work: http://www.irian.at

Mime
View raw message