myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan-Kees van Andel (JIRA)" <...@myfaces.apache.org>
Subject [jira] Created: (EXTSCRIPT-114) ExtScript fails to start when Groovy is not available
Date Sun, 18 Apr 2010 13:28:25 GMT
ExtScript fails to start when Groovy is not available
-----------------------------------------------------

                 Key: EXTSCRIPT-114
                 URL: https://issues.apache.org/jira/browse/EXTSCRIPT-114
             Project: MyFaces Extensions Scripting
          Issue Type: Bug
          Components: Core
    Affects Versions: 1.0-Beta-2
         Environment: Vista x64, Java 6, jetty-6.1.14
            Reporter: Jan-Kees van Andel
            Assignee: Werner Punz


When I don't add the groovy binaries to my Maven dependencies, and I run my app with maven-jetty-plugin,
I get the following exception:
2010-04-18 14:46:55.710::WARN:  Error starting handlers
java.lang.NoClassDefFoundError: groovy/lang/GroovyObject
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:616)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
	...

I don't want to use Groovy, but I do need the Groovy binaries for ExtScript to start.

Maybe this Exception should be used to automatically disable Groovy support?

Anyway, I personally don't mind to add Groovy, but I think it should be fixed before the 1.0
release b/c I think other users do mind.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message