myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leonardo Uribe (JIRA)" <...@myfaces.apache.org>
Subject [jira] Commented: (MYFACES-2290) Add OSGi bundle information and bundle classloader / activator
Date Wed, 17 Mar 2010 18:33:27 GMT

    [ https://issues.apache.org/jira/browse/MYFACES-2290?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12846516#action_12846516
] 

Leonardo Uribe commented on MYFACES-2290:
-----------------------------------------

I forget to say, it was also committed some fixes to make myfaces code more friendly with
osgi, including add a Require-Bundle header, so myfaces-api bundle can find myfaces-impl using
the bundle classloader.

> Add OSGi bundle information and bundle classloader / activator
> --------------------------------------------------------------
>
>                 Key: MYFACES-2290
>                 URL: https://issues.apache.org/jira/browse/MYFACES-2290
>             Project: MyFaces Core
>          Issue Type: New Feature
>          Components: General
>    Affects Versions: 1.2.8-SNAPSHOT
>         Environment: OSGi (Equinox, Apache Felix, ...)
>            Reporter: Felix Röthenbacher
>            Assignee: Leonardo Uribe
>            Priority: Critical
>         Attachments: allow-ee6-versioned-apis.diff, MYFACES-2290-no-activator-2.patch,
MYFACES-2290-no-activator.patch, myfaces-core.diff.txt, myfaces-shared.diff.txt, myfaces-test-helloworld-osgi-pax-web.zip,
myfaces-test-helloworld-osgi-springdm.zip
>
>
> The provided patch will add OSGi information to bundle manifest. A bundle activator class
makes the MyFaces framework aware that it is running in a bundle environment. A bundle classloader
is used to load classes and resources from the bundle classpath. The patch doesn't require
any new runtime dependencies and doesn't affect class loading in a non-OSGi environment. Though,
small modifications to classloading were needed. This was mainly replacing Thread.currentThread.getContextClassLoader()
with ClassUtils methods.
> To run MyFaces in an OSGi environment both bundles (myfaces-api and myfaces-impl) have
to be started in the OSGi container. Additionally, the myfaces-impl bundle has to be made
available to myfaces-api. Use a fragment bundle with myfaces-api as Fragment-Host and myfaces-impl
as Required-Bundle.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message