myfaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Günter D. (JIRA) <...@myfaces.apache.org>
Subject [jira] Created: (TRINIDAD-1741) Multiselection in tr:table doesn't work correctly anymore?
Date Mon, 01 Mar 2010 10:42:05 GMT
Multiselection in tr:table doesn't work correctly anymore?
----------------------------------------------------------

                 Key: TRINIDAD-1741
                 URL: https://issues.apache.org/jira/browse/TRINIDAD-1741
             Project: MyFaces Trinidad
          Issue Type: Bug
          Components: Components
         Environment: XP Home; Tomcat6.14.;jsf1.2;trinidad1.2.13
            Reporter: Günter D.


Since today i discovered the folowing wich once worked properly.
I have several tables with the opportunity for a multiple row selection. Only the first entry
in the table works correctly if you mark it as selected or unselected. The SelectionListener
is called, everything's fine.
But if I choose other rows it works only for the first time you do it. After that I have to
click several times to do a deselect of that row and the SelectionListener is never called
again??. Select All and Deselect all still work as expected.
If I sort the table by another column, so that i get a "different" first row, this will be
the one working properly and the other rows won't.
I use IE8, FF3.6 and tried it with FF3.5.6, everywhere the same.

Any help would be appreciated.
Best Regards

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message